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Getting Started 
Welcome to Ipswitch WhatsUp Professional 2005. This guide pro-
vides general information about using the product, as well as spe-
cific instructions on how to configure the application to work best 
in your network environment. 

How it Works
WhatsUp Professional 2005 is a powerful network monitoring 
solution designed to help you protect your growing business. 
WhatsUp Professional uses a relational database to store informa-
tion about the devices on your network that are being monitored by 
the application. That information allows the application to effec-
tively watch over your network by actively polling devices and ser-
vices, or by listening for messages sent across your network.

Depending on the response from this polling, WhatsUp Profes-
sional then fires Actions based on the device state change that is 
invoked by the response or message.

WhatsUp Professional provides a series of reports that lets you 
view historical data based on the devices and monitors configured 
in your device database.

New in WhatsUp Professional
These features were introduced in the original release of Ipswitch 
WhatsUp Professional 2005:

•  Relational database makes it easier to organize large networks

•  New Windows Explorer-like viewing options 

•  Secure (SSL) Web Server

•  Optional LDAP authentication for Web user accounts

•  Open architecture for Web Server

•  Better means of associating Actions and Monitors to devices

•  Improved reporting capabilities

 

In this Chapter

Setting Up FTP Hosts

Adding Additional FTP Hosts

Configuring an External User 
Database

Configuring an NT User 
Database

Setting Options for the FTP 
Host

Renaming an FTP Host

 

In this Chapter

How it Works

New in WhatsUp Professional

New in Service Pack 1

Finding More Information
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•  Monitor level data collection

•  Addition of a Maintenance mode for devices allows scheduling of down-time, when 
Monitoring will not be performed

•  Creation of custom device states

• Association of  Action Policies across devices

•  Improved mapping capabilities

•  Single device scanning

•  Attributes added to device definition

•  Improved usability across the entire application

New in Service Pack 1
These features are being introduced in WhatsUp Professional 2005 Service Pack 1: 

•  You can scan your network on a regularly scheduled basis using Active Discovery.

• Reports now can display times using a 24-hour clock,  and can be configured to display 
alternative date formats.

• You can simultaneously edit groups of devices with the Bulk Field Change feature.

• Improved security limits Web users’ access to specific device groups.

• You can test Active Monitors against any mapped device and obtain a debug report.

• You can configure multiple blackout periods for all Actions.

• You can define Up Actions to only fire after a specific Down state has been reached.

• A new logging system has been introduced, incorporating several new system level 
reports.

• Enhanced migration utility that allows you to import data from WhatsUp Gold at any-
time.

•  Integrated Acknowledgement system to warn you when any past Down state has 
occurred.

• Database backup and restore menus added to the main console.

Finding More Information
The documentation for WhatsUp Professional consists of three different parts, each part fit-
ting a specific user need, and containing a specific type of information.
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Online Help: contains dialog assistance and definitions, general configuration information, 
and how-tos that explain how to use the features. The Table of Contents is organized by 
functional area, and can be reached by selecting it from the main menu, or by pressing the 
[F1] key in any dialog.

Solutions Guide: directions and information that answer a specific use case or problem 
area. There is some general information here that frames solutions in the context of the 
application. There are also many handy tips and tricks that users of all levels may find use-
ful. The URL is: http://www.ipswitch.com/support/whatsup_professional/guides/index.asp
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Knowledge Base: You can search the Ipswitch Knowledge Base of technical support and 
customer service information. The URL is: http://support.ipswitch.com/kb/
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Installation
Installing WhatsUp Professional is straightforward, though the 
Release Notes are required reading due to possible Service Pack 
and database issues. 

The path you take to a successful installation may differ, 
depending on the following:

First-time Install

If you are installing WhatsUp Professional for the first time, the 
installation program does the following with no actions required of 
you.

• Installs the database server, which is Microsoft Server 2000 
Desktop Engine (MSDE 2000).

• Creates a WhatsUp database instance in MSDE.

• Creates a Data Source Name (DSN), which tells WhatsUp 
Professional where to find the WhatsUp database.

• Installs the WhatsUp Professional application.

Read the “System Requirements” on page 6, then follow the steps 
in “Installing or Upgrading” on page 7.

Upgrading

If you are upgrading from a previous version of WhatsUp 
Professional, the installation program detects an existing WhatsUp 
database and configures the new version to use that database, 
provided the following conditions are met:

• MSDE 2000 is installed on the computer on which you are 
installing WhatsUp Professional.

• The WhatsUp database exists on the database server.

• A DSN is configured for the WhatsUp database.

If these conditions are not met, the installation program will notify 
you and direct you to perform a manual installation of the 
database. 

In this Chapter

System Requirements

Installation Notes

Installing or Upgrading

Uninstalling

MSDE Database

Alternative Database Setups
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Read the “System Requirements” on page 6, then follow the steps in “Installing or 
Upgrading” on page 7, and if necessary, configure the database manually as shown in 
“Alternative Database Setups” on page 11.

Custom Database

Though we recommend that you use the default database (MSDE 2000), if you need to 
either use another database, or you need to run the database on another computer, you can set 
it up manually after the WhatsUp Professional installation has completed. For more 
information, see “Alternative Database Setups” on page 11.

System Requirements

Requirements for WhatsUp Professional

• Supported operating systems are: Windows 2003 Server; Windows XP SP1 or later; 
Windows 2000.

• 256 MB of free disk space

• 256 MB RAM

• To use pager, SMS, or beeper actions, a local modem and phone line is required 
(WhatsUp Professional does not support modem pooling).

• Text to Speech Actions require a sound card configured to use SAPI v5.1, which comes 
with Windows 2003 and Windows XP operating systems. SAPI v5.1 can be down-
loaded from:

http://www.microsoft.com/speech/download/sdk51/  

• To install the e-commerce version of the application, you will need an active internet 
connection.

Requirements for MSDE 2000

• MSDE has a 2 GB data limit. Make sure you select a large capacity drive for data 
storage.

Note: If you have Windows XP Service Pack 2 installed, you need to read the 
release notes regarding issues with this Service Pack before you install. 

Note: This is the requirement for installation. You will need more space for the 
database. An MSDE database can grow up to the 2 GB limit.
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• MSDE 2000 requires that Microsoft Internet Explorer 5.0 or later be installed. A mini-
mum installation is sufficient, and Internet Explorer does not have to be the default 
browser.

• File and print sharing must be active to install MSDE 2000.  To verify:

• Select Start > Settings > Network Connections.

• Select Advanced > Advanced Settings.

• On the Adaptors and Bindings tab, make sure the File and Print Sharing for 
Microsoft Networks option is selected.

Installation Notes
Read the Release Notes for information on potential installation issues, such as the 
following:

• Windows XP (SP2) Errors. This Service Pack enables firewall settings that can interfere 
with Microsoft SQL Server’s ability to listen on the network.

• MSDE 2000, Release A issues. Security policies may interfere with the installation of 
MSDE and Microsoft Data Access Components (MDAC). Some services may need to 
be stopped before installing Release A.

• MSDE Memory Usage. When WhatsUp Professional installs and configures a new 
instance of MSDE, it sets the default memory usage to 64 MB. If the install program 
detects an existing instance of SQL Server, or you do a manual installation of the data-
base server, the memory limit is not set.

Installing or Upgrading
The installation program is similar whether you are installing WhatsUp Professional for the 
first time or upgrading a previous installation. Steps that apply only to a first-time 
installation, or only to an upgrade, will be identified as such.

1 Log in to an Administrator account.

2 Start the installation program:

• If you purchased a WhatsUp CD-ROM, insert the CD-ROM into the appropriate 
drive. If it does not run automatically, click Start, select Run, and then enter the 
CD path followed by AutoRun.exe   For example: D:\AutoRun.exe

• If you downloaded WhatsUp Professional from our Web site, run the downloaded 
installation application.  
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3 Read the Welcome screen.

The Welcome screen urges you to disable any running antivirus software, estimates how 
long it takes to install the application, and displays a button that, once clicked, displays 
the release notes.

Click Next to continue. 

4 Read the license agreement. 

Select the appropriate option, then click Next. 

5 Select the default install directories for MSDE 2000. (For first-time installation only.) 

The application and data files will be installed in default directories. If you want to 
change the locations, click the browse buttons to find and select a different directory. 
Make sure you have a large capacity drive selected for data storage. Data files can grow 
up to the 2 GB MSDE limit.

Click Next to continue.

6 Select the installation directory for the WhatsUp Professional application files. 

The default path is C:\Program Files\Ipswitch\Whatsup Professional 2005.  It is 
recommended that you use the default, but you can choose a different path. Some users 
prefer to put application files on a partition separate from the operating system, which is 
usually installed on the C: drive, to isolate the application from an operating system 
crash. 

7 Choose how to handle existing Web and Report files. (For upgrade installation only.)

If you have previously installed WhatsUp Professional, you may already have Web and 
Report files stored in your installation directory. You can choose to either delete them or 
back them up during the install. Backup is recommended.

8 If a sound card is installed and it has SAPI-compatible drivers, the install program asks 
whether you want to install Text to Speech capabilities. If you select No, you can always 
return and install Text to Speech at a later date. 

9 Click Install to install the WhatsUp Professional application files.

WhatsUp Professional gives you the option to go back and change options or cancel 
prior to completing the installation. 

10 Installation of the core application is complete. You can read the Release Notes (which 
you should already have done!) and you can launch WhatsUp Professional. Make your 
selections, then click Finish. 

Note: If you want to customize your database setup, you need to first 
complete the installation, then manually configure your database as described 
in “Alternative Database Setups” on page 11.
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If you choose to launch now, the next screen introduces you to the Discover Devices 
wizard, which lets you set options on how to discover your network. If you choose to 
postpone these steps, click the Cancel button. For information on how to use the 
Discover Devices wizard, see “Devices” on page 23. 

11 Activate the WhatsUp Pro application. 

If you have a license key, click Activate Now. If you need a license key, click Purchase 
one. If you want to evaluate the application before purchasing, select Activate Later.

Online activation

a Click Internet.

b Complete the steps for online activation.

Offline activation

a Click Offline.

b Complete the steps for offline activation.

For more information about licensing, go to:

http://www.ipswitch.com/support/cs_center.html

Migrating Data from WhatsUp Gold
Chapter 3 of this guide describes how to migrate data from WhatsUp Gold versions 7 and 8 
to WhatsUp Professional 2005 SP1. You should complete the WhatsUp Professional 
installation before migrating your data.

Uninstalling
To uninstall WhatsUp Professional, click Start > Settings > Control Panel, then select Add 
or Remove Programs. Select Ipswitch WhatsUp Professional, then select Remove when 
prompted.

You can also run the Ipswitch WhatsUp Professional executable and select Remove.

http://www.ipswitch.com/support/cs_center.html
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The following dialog shows the uninstall options:

• If you are upgrading from WhatsUp Professional v1.0 to the SP1 release, you do not 
need to uninstall.

• If you have a beta or other test version of the SP1 release, before installing the new ver-
sion, you should uninstall and select the second option, but do not select to remove the 
WhatsUp database.

MSDE Database
The WhatsUp Professional installation program installs the MSDE 2000 database server and 
configures the WhatsUp database. As described on the MSDE Home page, “Microsoft SQL 
Server 2000 Desktop Engine (MSDE 2000) is the free, redistributable version of SQL 
Server that’s ideal for client applications that require an embedded database, new developers 
learning how to build data-driven applications, and Web sites serving up to 25 concurrent 
users.

For more information, go to: http://www.microsoft.com/sql/msde/

You can find a copy of the MSDE 2000 installation program on:

• WhatsUp Professional CD-ROM

http://www.microsoft.com/sql/msde/
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• Microsoft Developer Network. Go to http://msdn.microsoft.com and search on MSDE 
to find information on MSDE and the latest downloads.   

Alternative Database Setups
Though we strongly recommend using the default database, which is MSDE 2000, you can 
configure WhatsUp Professional to use a custom database. This requires manually 
configuring the database, so you need to know how to set up your particular database 
program. You may want to do this if you want to:

• Use a database other than MSDE 2000

• Run the database on a computer separate from the one on which you will install 
WhatsUp Professional.

Supported databases:

• MSDE 2000 

• Microsoft SQL Server 2000

What you need to do:

1 Make sure the database server is installed on the appropriate computer. We recommend 
installing as the named instance: “WhatsUp”

2 Create a database called WhatsUp. 

3 Create or edit the DSN that tells WhatsUp Professional where to find the custom data-
base.

How you complete these three steps depends on which database server you will use and 
whether the database server is on the same computer as WhatsUp Professional or on a 
separate computer.

The following sections outline the steps required given different scenarios.

Note: Microsoft has issued a patch to MSDE 2000. Go to the Microsoft 
website for more information, and for instructions on how to download this 
patch. 

http://support.microsoft.com/?kbid=815495

http://msdn.microsoft.com
http://support.microsoft.com/?kbid=815495
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Upgrading a Non-Default Configuration of MSDE 2000 or 
SQL Server 2000

Features in WhatsUp Professional 2005 (SP1) mandate an update of the original database 
schema. The following procedure steps through how to upgrade an installation of WhatsUp 
Professional that is a non-default configuration. A non-default configuration is one that does 
not meet the following conditions:

• MSDE 2000 is installed on the computer on which you are installing WhatsUp Profes-
sional.

• The WhatsUp database instance exists in MSDE.

• A WhatsUp DSN is configured to point to the WhatsUp database instance.

You must first complete the WhatsUp Professional installation, then upgrade the database.

The WhatsUp Professional installation program will notify you if the database is in a non-
default configuration. The procedures differ depending on whether the database server is on 
the same computer as WhatsUp Professional.  

To upgrade the database from the WhatsUp Professional 2005 format to WhatsUp 
Professional 2005 (SP1) format, follow these steps:

1 If your WhatsUp database is not on the same computer as WhatsUp Professional, copy 
the DB Scripts directory and the Upgrade Scripts sub-directory to the remote server. 
Make note of the fully qualified path to the DB Scripts directory, as it will be required in 
the steps that follow.

Note: Before updating the database schema, we recommend that you take the time to 
backup your existing data. To do so, execute the following SQL Command within the 
SQL Server Query Analyzer:

BACKUP DATABASE WhatsUp TO DISK='{path}\db_backup.dat'

  ex: BACKUP DATABASE WhatsUp TO DISK='C:\db_backup.dat'

Or,

Use the osql command to back up the database:

Osql -E -D <DSN> -Q “BACKUP DATABASE WhatsUp TO 
DISK= ‘{path}\db_backup.dat’”

    Or,

Osql -E -S <machine\instance name> -Q “BACKUP DATABASE WhatsUp TO
DISK= ‘{path}\db_backup.dat’”
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2 On the computer on which the database server is installed, from the command prompt 
window, go to the Upgrade Script sub-directory of the DB Scripts directory.

3 Run the upgrade scripts, by running the Visual Basic (VB) script which runs each script 
in sequence, or by running each script individually.

VB Script:

In the command prompt window execute the following VB script: 

upgrade_db.vbs -E -S <sql server name> -d whatsup

where the argument, sql server name, specifies the machine name\database instance 
name.

For example:

upgrade_db.vbs -E -S computer123\MySqlServerInstanceName 
-d whatsup 

The VB script executes all the upgrade scripts that are  found in the current directory 
and have filename pattern upgrade_from_??????_to_*.sql

Manually run the upgrade scripts:

The alternative to using the VB script is to manually execute the upgrade scripts on the SQL 
Server machine, as follows:

1 The Upgrade scripts are found in a sub-directory within the DB Scripts directory named 
Upgrade Scripts. Using Notepad or a similar text editor, open the file 
upgrade_from_102001_to_102002.sql. Use the Edit > Replace function to find the two 
occurrences of the <DATAFILESPATH> placeholder, and replace it with the path to the 
DB Scripts directory. Note: No trailing slash should be used in the replacement string. 
Save the updated file.

2 Run the scripts by using SQL Server Enterprise Manager (available on the SQL Server 
CD), or the osql command.

SQL Enterprise Manager

IMPORTANT!!! Open the SQL Server Enterprise Manager and select the server 
running the "WhatsUp" database. From the Enterprise Manager, open the SQL Server 
Query Analyzer, and select the "WhatsUp" database in the drop-down selector found in 
the toolbar.

Using the SQL Server Query Analyzer, load, and then execute (F5), the following 
scripts in the order listed:

Note: If the SQL Server and WhatsUp Professional are on the same machine, 
then run upgrade.vbs without specifying any arguments.
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  1 - upgrade_from_101206_to_102.sql

  2 - upgrade_from_102001_to_102002.sql (Script updated in Step 2)

  3 - upgrade_from_102002_to_102003.sql

  4 - upgrade_from_102003_to_102004.sql

  5 - upgrade_from_102004_to_102005.sql

  6 - upgrade_from_102005_to_102102.sql

  7 - upgrade_from_102102_to_102103.sql

  8 - upgrade_from_102103_to_102202.sql

Osql command:

Run the scripts in the order shown above using the osql command as follows:

osql -E -S <sql server name> -d whatsup 
-i <script name.sql> {-o errorlog.txt}

For example:

osql -E -S computer123\MySqlServerInstanceName -d whatsup 
-i upgrade_from_101206_to_102.sql -o errorlog.txt

Following successful execution of the scripts, your WhatsUp Professional 2005 (SP1) 
database will be up-to-date and ready for use by WhatsUp Professional 2005 (SP1). All 
data previously collected should be present within the updated database.

3 Select Control Panel > Administrative Tools > Services and verify that the status of 
Ipswitch WhatsUp Engine service is Started. If it is not, start the service. You can 
now launch NMConsole.exe or start the application via the program shortcuts.

Creating a new WhatsUp Database on an Existing SQL 
Server on the Same Computer

This procedure steps you through creating a new WhatsUp database on an existing SQL 
Server installation that is on the same computer with WhatsUp Professional.   

You must first complete the WhatsUp Professional installation, then configure Microsoft 
SQL Server 2000.

1 Move the database to the SQL Server instance.

a Backup the clean MSDE 2000 WhatsUp database.

From the WhatsUp Professional console, select Tools > Database Utilities > Back Up 
SQL Database. Enter a name for the backup file, for example: SP1cleanDB.dat 
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Or, from the command line, enter:

osql -E -D whatsup -Q “backup database to 
disk=’C:\SP1cleanDB.dat’”

b Restore the backup to your SQL Server. From the directory where the you saved 
the backup file, run:

osql -E -S <sql server name> -Q “restore database whatsup 
from disk=’<the .dat file> with Move ‘whatsup_dat’ to 
‘<location for the mdf file>’, Move ‘whatsup_log’ to 
‘<location for the ldf file>’”

Substitute the <...> with your values:

<sql server name> = machine name\instance name
<the .dat file> = the backup file from the previous step (step a)
<location for the mdf file> = where you would like to keep the mdf file (data file used 
by the database)
<location for the ldf file> = where you would like to keep the ldf file (log file used by 
the database)

For example:

osql -E -S rra997\mySqlServerInstanceName -Q "restore 
database whatsup from disk='D:\SP1cleanDB.dat' with Move 
'whatsup_dat' to 'D:\Program Files\Microsoft SQL 
Server\MSSQL$mySqlServerInstanceName\Data', Move 
'whatsup_log' to 'D:\Program Files\Microsoft SQL 
Server\MSSQL$mySqlServerInstanceName\Data'"

3 Remove Service Dependencies. You need to remove the Ipswitch WhatsUp Engine ser-
vice’s dependence on MSSQL$WHATSUP, which is the MSDE instance created by the 
WhatsUp Professional installation. To do this:

a At the DOS prompt, navigate to the directory where WhatsUp Professional is 
installed, and enter:  Nmservice /Service: 

b At the DOS prompt, enter:  NmService /Service:<MS SQL Server Service Name> 
For example: NmService /Service:MSSQL$mySqlServerInstanceName 

c Go to Control Panel > Administrative Tools > Services, then start the Ipswitch 
WhatsUp Engine Service.

On some operating systems, you may have to reboot the machine before 
continuing.
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4 Configure the Data Source Name (DSN).

a On the computer on which Ipswitch WhatsUp Professional 2005 SP1 was installed, 
click Start > Settings > Control Panel > Administrative Tools > Data Sources 
(ODBC).

b Click the System DSN tab. Click Configure to modify the WhatsUp DSN. In the 
Server box, enter: <machine name\sql server instance name>

For example:

computer123\mySqlServerInstanceName

c Click Finish.

Creating a New WhatsUp Database on an Existing SQL 
Server on a Remote Computer

This procedure steps you through creating a new WhatsUp database on an existing SQL 
Server installation on a remote computer. 

You must first complete the WhatsUp Professional installation, then configure Microsoft 
SQL Server 2000.

1 Move the database to the SQL Server instance.

a Backup the clean MSDE 2000 WhatsUp database.

From the WhatsUp Professional console, select Tools > Database Utilities > Back Up 
SQL Database. Enter a name for the backup file, for example: SP1cleanDB.dat 

OR, from the command line, enter:

osql -E -D whatsup -Q “backup database to 
disk=’C:\SP1cleanDB.dat’”

2 On the WhatsUp Professional computer, create a System Data Source Name (DSN). 

a On the computer on which Ipswitch WhatsUp Professional 2005 SP1 was installed, 
click Start > Settings > Control Panel > Administrative Tools > Data Sources 
(ODBC).

b Click the System DSN tab. The recommended DSN Name used by WhatsUp Pro-
fessional 2005 SP1 is "WhatsUp", however, you may use any acceptable DSN 
Name.

c Select SQL Server Authentication. You can specify sa (the default) as the 
LoginID, and its password as an alternative. You can use any LoginID and 
Password with rights to the WhatsUp database, which requires additional configu-
ration on the remote SQL Server.
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d Make sure the Change the default database to option is selected, and that the 
default database is "WhatsUp".

e In the final screen of the DSN wizard, click the Test Data  Source button. Make 
sure the test is successful.

3 Run NMCONFIG.EXE. This program makes sure that WhatsUp Professional SP1 has 
the account information needed to log on to the database. The NMCONFIG dialog 
appears.

a Enter the DSN name created in Step 5.

b Enter a Username ("sa" is the default.) 

c Enter the Password for this Username (the one you specified in Step 5). The default 
password is: “wug_sa”

4 Remove service dependencies. You need to remove the Ipswitch WhatsUp Engine ser-
vice’s dependence on MSSQL$WHATSUP, which is the MSDE instance created by the 
WhatsUp Professional installation. To do this:

a At the DOS prompt, navigate to the directory where WhatsUp Professional is 
installed, and enter:  Nmservice /Service: 

b At the DOS prompt, enter (for the second time:)  NmService /Service: 

c Go to Control Panel > Administrative Tools > Services, then start the Ipswitch 
WhatsUp Engine Service.

5 Launch the application.

a Select Start > Programs > Ipswitch WhatsUp Professional 2005 > Ipswitch 
WhatsUp Professional 2005.

b Select Start > Programs > Ipswitch WhatsUp Professional 2005 >Ipswitch 
WhatsUp Professional 2005 Task Tray Application.

Installing a New SQL Server Instance and Creating a New 
WhatsUp Database

This procedure steps through a new installation of SQL Server on the same computer on 
which you installed WhatsUp Professional.

1 Backup the clean MSDE 2000 WhatsUp database.

From the WhatsUp Professional console, select Tools > Database Utilities > Back Up 
SQL Database. Enter a name for the backup file, for example: SP1cleanDB.dat 

On some operating systems, you may have to reboot the machine before 
continuing.
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OR, from the command line, enter:

osql -E -D whatsup -Q “backup database to 
disk=’C:\SP1cleanDB.dat’”

2 Uninstall MSDE at Add/Remove Programs > Microsoft SQL Desktop Engine. Then 
delete the whatsup.mdf and whatsup.ldf files in :\Program Files\Microsoft SQL 
Server\MSSQL$WHATSUP\Data

3 Install the SQL server, and during install please specify the instance name: WhatsUp. 
From the Services Control manager, start MSSQL$WHATSUP service  - (Control 
Panel > Administrative Tools > Services).

4 Restore the backup to your SQL Server. 

osql -E -S <sql server name> -Q “restore database whatsup 
from disk=’<the .dat file> with Move ‘whatsup_dat’ to 
‘<location for the mdf file>’, Move ‘whatsup_log’ to 
‘<location for the ldf file>’”

Substitute the <...> with your values:

<sql server name> = machine name\instance name
<the .dat file> = the backup file from the previous step (step a)
<location for the mdf file> = where you would like to keep the mdf file (data file used 
by the database)
<location for the ldf file> = where you would like to keep the ldf file (log file used by 
the database)

For example:

osql -E -S rra997\mySqlServerInstanceName -Q "restore 
database whatsup from disk='D:\SP1cleanDB.dat' with Move 
'whatsup_dat' to 'D:\Program Files\Microsoft SQL 
Server\MSSQL$mySqlServerInstanceName\Data', Move 
'whatsup_log' to 'D:\Program Files\Microsoft SQL 
Server\MSSQL$mySqlServerInstanceName\Data'"
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Migrating from WhatsUp 
Gold

WhatsUp Professional goes well beyond being a newer version of 
WhatsUp Gold. WhatsUp Professional offers a completely rede-
signed user interface, a new polling engine, a new database struc-
ture for storing information about devices, and a new philosophy 
of user interaction. Processes have been streamlined to make the 
application easier to use and more robust in its functionality.

When moving from WhatsUp Gold to WhatsUp Professional, you 
will immediately notice the changes made to the application. How-
ever, the philosophy changes may take a little longer to grasp. 

Philosophy Changes
In WhatsUp Gold, everything was centered around device maps. 
Those maps were used to monitor devices, edit device entries, and 
display relational information between the devices on the map. If 
you had multiple locations, or even multiple subnets in each loca-
tion, you had to have several maps open in your WhatsUp window 
to monitor them all at once. Furthermore, maps were independent 
of each other, meaning that you could not have dependencies 
across maps or have the same device entry on multiple maps (with-
out the device being polled by each map.) 

While maps are still used in WhatsUp Professional, they are now 
graphical representations of Device Groups, and one of two ways 
to display the devices in those groups. The primary means is 
through the Device List view. This view has a familiar folder and 
item feel to it, and is very useful when handling multiple device 
groups or large numbers of devices. 

In Gold, maps handled the polling of the devices on that map. In 
Professional, there is a single database that stores all device infor-
mation across all device groups. 
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In short, the Device List has replaced the WhatsUp Gold Maps as the main interface between 
the user and the polling engine. This gives the users the ability to make dependencies across 
their network, and to have devices appear in multiple groups with the same information in 
each entry. 

Terminology Changes
The following table is a comparison between terminology used previously in WhatsUp 
Gold, and what is used now in WhatsUp Professional. 

Migrating Data from WhatsUp Gold to 
WhatsUp Professional

The WhatsUp Gold to WhatsUp Professional Data Migration Utility migrates information 
from WhatsUp Gold versions 7 or 8 data files to the WhatsUp Professional 2005 SP1 data-
base. The following is a list of the items that can be migrated through the use of this utility:

• Maps

• Service Definitions

• Events Library Definitions

• Notification Library Definitions

• Custom Device Type Definitions

• Trap Definitions

This utility can be run at any time during the operation of WhatsUp Professional, and can be 
run multiple times. Each time the utility is run, imported maps and devices will be dupli-
cated in the WhatsUp Professional database, but duplicate definitions are not imported or 
updated. If XYZ already exists in the Whats Up Professional database, XYZ is ignored, even 
if the definition was updated in WhatsUp Gold in the meantime.

WhatsUp Gold WhatsUp Professional 

Events Passive Monitors 

Monitors and Services Active Monitors

Notifications Actions

Map Device Group or Device Map
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Using the Migration Utility

Access the Migration Utility from the WhatsUp Professional Console main menu by select-
ing Tools > WhatsUp Gold Data Migration. The migration utility is actually a wizard that 
walks you through each step in the process.

Back up first!

Before you migrate data into the WhatsUp Professional database, you should back up the 
current  database using the Back Up SQL Database utility. The migration utility will not 
damage the database, but some of the results may be confusing if you are not familiar with 
new WhatsUp Professional terminiology. 

To back up the database: from the WhatsUp Professional main menu, select Tools > Data-
base Utilities > Back up SQL Database.

Selecting the data source

Select the path to the WhatsUp Gold install that you want to migrate into the WhatsUp Pro-
fessional database. The path can be any drive that is local or mapped on the WhatsUp Pro-
fessional computer. The drive must be mapped, and the connection previously established, as 
the UNC name is not recognized as a valid drive.

This directory contains the WhatsUp Gold configuration definitions, but not your WhatsUp 
Gold map files. You are given the ability to select your map files in the next dialog in this 
utility.

Be aware that modem settings for pagers and beepers will not be migrated during this pro-
cess, as these settings reside in the registry. Review the pager/beeper definitions once 
they’ve been migrated to ensure modem settings are correct.

Selecting Maps to transfer

Browse and select the map files that you want to import into the WhatsUp Professional data-
base. These files can reside on any mapped drive on your network, and may be any valid 
map file type (wup, xml, or ini.)

If you want to only import definitions and not your WhatsUp Gold maps, you may leave this 
list blank.

Note: There may be an issue with custom icons, sound files, background images, and 
program notifications being imported when migrating WhatsUp Gold data from a 
remote drive. Since the WhatsUp Gold definition files may reference absolute directory 
locations, these types of files may need to be copied manually and re-setup for use in 
WhatsUp Professional.
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Viewing the migration report

Once the utility completes the migration of the maps and configuration definitions, the 
migration utility displays the migration report.

Be sure to read through the results and review any warning or error that you may find. If 
there is an error with an imported file, review the file that was affected.

If there is an SQL error, be aware that the problem may be an unexpected setup or condition 
and you may need to contact Ipswitch Technical Support or search the Knowledge Base for a 
potential work-around.

Trigger time warnings may affect your desired notification settings. Review those triggers 
and determine which best suits your needs. You can change those settings to a predefined 
state change, or create a new one to more closely match your WhatsUp Gold Settings and 
then re-import.

If you would like to view this log later, you can access it at any time from the <WhatsUp 
Professional install directory>/data/logs directory, as it contains a history of all migration 
attempts. This log is also useful for customer support calls.

Warning: Be certain you are ready to begin importing data before you click Next. As 
soon as the process begins, data is being written to the database, and can not be 
'backed out' without restoring a previously backed up database. You can stop the 
process, but any data written to the database will stay there until it is removed 
manually or overwritten during the database restore.

Note: If devices are duplicated in the imported WhatsUp Gold map files, WhatsUp 
Professional creates duplicate devices for each that is found. Each device instance will 
be polled as if it were a different device. You may want to condense these entries after 
completing the migration, creating shortcuts in the device groups for each duplicated 
device.

Note: Remember that maps are already live in your database, and are already being 
polled and alerts are active.
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Devices
In WhatsUp Professional, devices are virtual representations of 
resources (computers, servers, hubs, etc.) that are connected to 
your computer through a LAN, a wireless network, or even over 
the Internet. WhatsUp Professional watches these devices through 
the network connection. When those network resources can't be 
reached by WhatsUp Professional, the device is considered down, 
and an Action can be configured to fire.

Device Troubleshooting?
WhatsUp Professional is not a troubleshooting tool. It will tell you 
when your network goes up or down, but will not tell you what 
made your network go down. For that, you will need to inspect the 
afflicted resource and its respective documentation. 

Device Services
WhatsUp Professional associates Active Monitors with devices on 
your network. Active monitors query the network services 
installed on a device and then wait for a response. These monitors 
“watch” the services running on a network resource, checking to 
make sure that the FTP server, web server, e-mail server, etc., is up 
and responding. Active Monitors include DNS, SNMP, Telnet, 
Ping, TCPIP, and NT Service. Quite simply, if a response is either 
not received or is not what is expected, the service is considered 
down. If the query is returned as expected, the service is 
considered up. If any one service on a device is down, then the 
device as a whole is considered down.

Device Types
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Device Properties

You can modify individual device properties by right-clicking on the device icon in either 
Device or Map View, and selecting Properties. There are nine separate Properties available. 
Their descriptions follow. Click the icons in the left viewing pane to view or modify each 
property. 

Device Properties - General

The General section of the device properties dialog box lists, or allows you to modify basic 
information for the selected device.

• Display name - An identifying name for the current device. This name is populated 
during Discovery, but can be changed at any time. Changing the name will not change 
how the device is polled, only how it is displayed in WhatsUp Professional.

• Polling type - Select the type of polling you want WhatsUp Professional to use for this 
device. 

• ICMP (TCP/UDP)

• IPX

• NetBios  

Note: If NetBIOS is selected, the Host Name box must contain a valid NetBIOS name. 
If  IPX is selected, the Address box must contain a valid IPX address. If NetBIOS or 
IPX is selected, you cannot monitor TCP/IP services on this device.
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• Poll using - Select whether you want WhatsUp Professional to use the IP address or the 
name (DNS) of the device for polling.

•  Host name (DNS) - This should be the official network name of the device if the poll-
ing method is ICMP. The network name must be a name that can be resolved to an IP 
address. If the polling method is NetBIOS or IPX, this must be the NetBIOS or IPX 
name.

• Address - Enter an IP or IPX address. 

• Additional Network Interfaces - Click this button to configure an additional Network 
Interface for the current device.

• Device Type - Select the appropriate device type from the pull-down menu. The icon 
displayed will represent the device in all views.

Device Properties - Active Monitors

This dialog is used to display and manage Active Monitors for this device. There are several 
ways that an Active Monitor can be added to this list: 

• Click Add to configure a new Active Monitor. 

• Select an Active Monitor and click Edit to change the configuration.

• Select an Active Monitor and click Remove to remove the monitor from the device.
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• Click Discover to have WhatsUp Professional scan the device for Active Monitors.

For more detailed information, see Chapter 7 - “Active Monitors.” 

Device Properties - Passive Monitors

This dialog displays all Passive Monitors configured for this device.

• Click Add to configure a new Passive Monitor.

• Select a Passive Monitor and click Edit to change the configuration.

• Select a Passive Monitor and click Remove to remove the monitor from the device.

For more detailed information, see Chapter 8 - “Passive Monitors.” 
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Device Properties - Actions

On this dialog, you can select an Action Policy to use on the selected device or configure 
actions specifically for this device. 

To apply an Action Policy to the device, select one from the action policy pull-down menu. 
You can also create a new action policy or edit an existing action policy, by clicking the 
Browse button next to the pull-down menu box.

Alternatively, configured actions appear in the Apply individual actions list, displaying the 
action type that is to be fired and the state change that will trigger the action. You may have 
multiple actions on a single device.

• Click Add to configure an action for the device.

• Select a configured action and click Edit to change the settings for that action.

• Select a configured action and click Remove to delete the action from the list.

See Chapter 10 - “Actions” for more detailed information.
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Device Properties - SNMP

This dialog displays a device’s SNMP properties. Simple Network Management Protocol is 
the protocol governing network management and monitoring of network devices and their 
functions. If the SNMP manageable device option is selected during Discovery, the correct 
SNMP community string was used during the discovery process, and if the device is SNMP 
manageable, then this option is selected automatically. If one or more of these conditions are 
not met, the option will be cleared, and the rest of the dialog will be unavailable. 

You can manually select or clear the SNMP manageable device option as your devices 
change or if you do not want the device to show up as SNMP manageable.

• Read community - This is a password used by WhatsUp Professional to read the 
device’s SNMP data.

• Write community -A password that gives write access to the device's SNMP data.

• Device Object ID (OID) - The SNMP object identifier for the device. This identifier 
may have been used during discovery to determine the device’s device type.

Note: SNMP manageable devices appear on the map view with a white star in the top 
right corner of its icon.
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Device Properties - Polling

Briefly, polling is the term used for the monitoring of discovered devices in WhatsUp 
Professional. This dialog allows you to configure polling options and/or schedule 
maintenance times for the selected device.

Polling

• Poll interval - This number determines how often WhatsUp Professional will poll the 
selected device. Enter the number of seconds you want to pass between polls. 

• Collect Active Monitor statistical data for reports - Select this option to have 
WhatsUp Professional collect round-trip-time for ping montitors on the device. The 
data appears in the Group and Device Performance reports.

Maintenance 

With this section, you can manually set the maintenance state on a device, or schedule a 
weekly maintenance state for a certain time period. Any device placed in maintenance mode 
will not be polled,  and actions will not be fired, but it remains in the device list and 
historical data is preserved. By default, the maintenance state is represented by an orange 
background color.

• Manually put this device into maintenance mode now - Select this option to put the 
device in maintenance mode. Clear the option to resume polling the device.
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• Scheduled maintenance times - This box displays all scheduled maintenance times for 
the device. 

• Click Add to schedule a new maintenance time for the device.

• Select an entry and click Edit to change a scheduled time.

• Select an entry and click Remove to delete a scheduled time from the list.

Dependencies

By default, WhatsUp Professional polls all devices and monitors in your device list, unless 
you manually turn off polling for the system as a whole, or at the device and monitor level. 
The dependency feature gives you the ability to avoid turning off polling to devices, and 
instead makes polling dependant on the status of another device in your database. 

There are two types of dependencies:

• Up Dependency can be thought of as describing that something is “behind” something 
else. The dependant device will only be polled if the device "in front" of it is up.

• Down Dependency can be thought of as describing that something is “in front of” 
something else. The dependant devices in front will not be polled unless the device fur-
ther down the line is down.

A valuable reason you might want to set dependencies on another device, is to limit 
notification actions being fired. 

For example: if you make devices behind a router , up dependant on the router, those devices 
will not be polled unless that router is up. If the router goes down, the devices will be placed 
in the unknown state. Without the dependency, the devices behind the router would fire off 
actions when they become unreachable due to the router going down. With the dependency, 
only actions on the router will fire.
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Device Properties - Notes

This section of the Device Properties dialog gives you the ability to enter free-form notes to 
the device database. By default, the first line of the Notes box shows when the device was 
added to the database. If viewing the Notes on a device shortcut, you will still see the date 
and time the device was added to the database, and not when the shortcut was created.

You may want to record historical information about a device, physical location information, 
or perhaps notes relating to the actions configured for the device. The use of this section is 
completely up to you.
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Device Properties - Menu

Use this dialog to create a context menu for a device. Once a new menu item has been 
configured, it appears on the right-mouse menu when you right-click on that device in the 
device list. When you select the menu item, the associated command is launched with the 
arguments that have been entered in its configuration.

• Customize the menu on this device (don't use device type menu) - Select this option 
to create and/or modify a context menu for this device. This will override any separate 
context menu that has already been created for the device type of the device.

• Menu list - This box displays the commands that are currently configured for the 
device. 

• Click Add to add a new menu item.

• Select an item and click Edit to change the settings.

• Select an item and click Remove to remove it from the list.

Note: Menu items configured in theconsole are not visible in the Web 
interface. Custom links created in the Web interface are notvisible here in the 
console.
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Device Properties - Attributes

This dialog lists attributes added to a device, such as contact person, location, etc. The first 
attributes in the list are added by WhatsUp Professional when the device is added to the 
database, either by the Device Discovery wizard, or through another means.

• Click Add to create a new attribute for the device.

• Select an existing attribute and click Edit to change the attribute.

• Select an existing attribute and click Remove to remove the attribute from the device.
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Device Types
In the left-hand pane of the WhatsUp Professional console interface, the Device Types (icons 
representing the types of devices you might have on your network)  appear.  You can click 
the tab at the bottom of the pane to switch from Device Types (Basic) to Device Types 
(Advanced). To use these icons to add new devices to be monitored, see “Device Properties” 
on page 24 in this chapter.
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Device Groups

Organizing Device Groups

In essence, device groups are organizational folders that allow you to quickly find and 
diagnose problems with devices in your database. You can organize these folders in any way 
that makes sense to you, so feel free to experiment with different configurations.

For a more detailed discussion on WhatsUp Professionals Views, see Chapter 5, “Using the 
WhatsUp Professional Console.” 

Map View

The Map View is based on the device group folders, meaning that you will have a different 
map for each device group. If a folder contains a subfolder, you can double-click on the 
folder in the map view to display the map in the subfolder. Double clicking a device opes the 
Device Properties.

Discovery

During Discovery, device groups are created for each subnetwork that is found on the 
network that was scanned. At the top level of the My Network tree, the entire scan is 
contained in a folder identifying the type of scan that was made and the date the scan was 
made. Devices that are already in the database are added to the new scan tree as a shortcut to 
the original device reference. In other words, there may be more than one reference in the 
My Network tree to one device. However, you can configure this same device by clicking 
either the original reference icon or the shortcut. Functionally, they serve the same purpose 
and display the same device state change.

Device State

Each folder in the My Network tree has a device state indicator on the folder icon. This 
indicator shows the worst state across all of the devices contained in that folder.

The green square in the right-hand corner of the folder icon indicates that all monitors on all 
devices are Up.

 The red square in the right-hand corner of the folder icon indicates that at least one monitor 
is Down.
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Renaming a Device Group

Right-click on the group in the My Network tree or Device View and select Rename from 
the menu.

Editing Multiple Devices - Bulk Field Change
The Bulk Field Change feature gives you the ability to make changes to multiple devices and 
device groups, if you have administrative privileges to these devices or device groups.  To 
edit multiple devices:

• In the Console, select the devices and device groups you want to change, then right-
click and select Bulk Field Change from the right-click menu. 

• In the Web interface, click the Bulk Field Change button, then select the devices or 
groups whose field you wish to change and again, click the Bulk Field Change button.

• In the Console, select the field you want to change from the fly-out menu. In the Web 
interface, click the select the checkbox(es) for the field you want to change.

Note: When you select a device group, every device in that group and in any 
subgroup in that group will reflect the bulk field change.
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• On the dialog for that setting, enter the configuration information that you want set.

• Click OK to commit the changes and return to the device list.

The following are the items that can be modified through Bulk Field Change.

• Action Policy

• Attribute

• Collect Statistics

• Device Type

• Down Dependency

• Maintenance Mode

• Notes

• Polling Interval

• SNMP Read Community

• SNMP Write Community

• Up Dependency

Acknowledgements
When a device state changes, regardless of any action that has been placed on the device,  
WhatsUp Professional uses the Acknowledgement feature to make you aware that the state 
change occurred. The name of the device appears in bold in the Device List, and in the Map 
View, the device name appears on a black background. 
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Once the device is in Acknowledgement mode, it will remain until you actively 
acknowledge it.

Acknowledging a State Change

• Select the device or devices you want to acknowledge and right-click on a selected item. 
In the right-mouse menu, select Acknowledge.

Or

• Access the State Change Acknowledgement Report in the Report View and select the 
devices you want to acknowledge. Once the devices are selected, click Clear  to remove 
the devices from the report, thereby acknowledging the state change.

Note: Acknowledging a device state change does not keep that device from firing 
actions. To stop a device from firing actions, you must put the device into maintenance 
mode.
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Using the WhatsUp 
Professional Console

The WhatsUp Professional Console is your primary interface to 
the configuration and management of the application and the data-
base that drives it. This chapter describes the different parts of the 
console, how to navigate the interface, and what you need to know 
to get started using it. 

Console Overview

The following is a breakdown of the main features found on the 
WhatsUp Professional Console. 

1 Device Group Tree. This is a list of all device groups created 
through WhatsUp Professional. When you perform a discov-
ery scan, WhatsUp Professional creates a top level folder for 
that particular scan. All discovered subnetworks are created in 
subgroups, but can be organized, deleted, or renamed to fit 
your needs.

 

In this Chapter

Setting Up FTP Hosts

Adding Additional FTP Hosts

Configuring an External User 
Database

Configuring an NT User 
Database

Setting Options for the FTP 
Host

Renaming an FTP Host

 

In this Chapter

Console Overview

Device View

Map View

Report View



40

CHAPTER 5 Using the WhatsUp Professional Console

2 View pane. This pane displays the selected device group based on the view  from the 
tabs below. See #3. If the Report view is selected, your WhatsUp Professional reports 
are displayed in this pane.

3 View selectors. Choose the way you want to view your device groups. Each of these 
views are explained in detail later in this chapter.

• Device View. This view provides an overview of each device and subgroup  in a 
selected device group.

• Map View. This view shows a graphical representation of the devices and sub-
groups in a selected device group.

• Report View. Use the Report View to troubleshoot and monitor historical data that 
has been collected during the operation of WhatsUp Professional.

4 Device Type Groups. Click the Basic or Advanced tab to view the device types con-
tained in that section. These types can be dragged into the view pane to create a new 
device based on that device type.

5 Polling Indicator Icons. These icons indicate the current state of the poll engine.

6 WhatsUp Professional Toolbar. The icons on this toolbar change according to the 
view you are currently using. Additional toolbar icons can be enabled for the Map view 
by selecting View > Toolbars.

Device View
With a similar look and feel to Windows Explorer, WhatsUp Professional's Device View 
gives you another option to help you keep your complex network organized and performing 
properly. In this view, devices are organized by device group, and appear in the list in alpha-
betical order based on the name of the folder or the display name of the device.

Poll engine is 
connected.

Poll engine is not 
connected

Polling is enabled Polling is disabled
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 Each device's icon provides information about its device state and the state of the monitors 
associated to that device. In addition, the Status column indicates which specific monitor  is 
down and the duration of the interruption. 

When the entry in the Device list is a group folder, the Status column shows the number of 
devices in the group with a breakdown of how many devices are in each device state.

Device Icons

The following icons appear in the Device View when viewing the contents of a device group. 

All monitors on the device are considered up.

Device is considered down, because one or more monitors are down. The 
green square shows that at least one monitor is responding.

Device entry appears in another device group. At least one monitor on the 
device is unresponsive, but at least one is considered up.

Device is currently in maintenance mode.

Device group contains at least one device that is considered down.

Device group is empty, or devices have not been polled due to a dependency 
on another device. 

A bold device name shows that the device has undergone a state change, and 
that state change has not been acknowledged. For more information about 
Acknowledgements, see Chapter 4 - “Devices.”
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Organizing Devices and Device Groups

While in the Device View, you can quickly and easily organize your devices and device 
groups, simply by dragging the device you want in a particular group to that device group 
folder. Once you ‘drop’ the icon or icons, a dialog appears, asking if you want to Move or 
Share those devices. If you move the devices, the they are deleted from the previous device 
group. If you share the devices, the devices appear in both device groups. 

Map View
Through the Map View of WhatsUp Professional, you have the ability to create  graphical 
representations of your network, organized by any means that suits your needs. Devices can 
be placed on as many maps as needed, without those devices being polled multiple times. In 
short, there is an enormous amount of flexibility in the way this feature can be used.

 

The map above was created by WhatsUp Professional during an SNMP Scan during Device 
Discovery. It shows the relationship between the different subnetworks that are connected to 
each other via the network structures depicted here. 

Note: Devices that are shared between two or more groups share common device 
properties. Therefore, you only have to change the settings on one device entry 
instead of remembering where each device is stored. This also means that each device 
is only polled once, no matter how many times it appears in your device group tree.
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Device Layout

The WhatsUp Professional Map View has a number of options you can use to organize your 
view of devices. Arrange options are available from the Arrange menu on the main menu bar 
and right-click menu. Display options are available from the View menu on the main menu 
bar and the toolbar. 

Try the different functions on the Arrange menu until you are satisfied with the device lay-
out. Be aware that there is no undo option for the arrange tool.

For example, to clean up a map after completing Discovery, you can try the following dis-
play options:

1 Select the device group, and click the Map View tab.

2 Right-click in the Map View and select Display > Clip Device Names. This removes 
the domain part of the device name and shows only the host name.

3 Select all devices in the view by clicking and dragging a selection box around all 
devices. Then, from the Arrange menu, select Distribute > Device Icons in Rows.

If you have a large set of devices or want to represent a topology specific to your network, 
you can also use the graphics annotations (such as lines, text, circles) and attached lines to 
create custom map views.

You can select object(s) in the map, right-click and select Lock Position from the menu. 
Lock Position keeps an object from moving as you move other items around, or when adding 
devices to the map. If you want an object to be able to change positions on the map, remove 
the "lock position" selection. It is very useful to lock images you may place in the back-
ground, or text you want to protect.

Map View Arrange Toolbar

See the application’s Online Help for more information on how to use specific features 
of the Map View, including grouping, using grid lines, and further manipulating of 
annotation objects.
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Adding Annotations to a Map

Annotations are graphical tools that let you customize a map view. You can add text, shapes, 
lines, and graphics to visually organize a set of devices.

In the Map View toolbar, click an annotation icon to make it the active tool. Then, you can 
drag the cursor on a map to create a line, rectangle, circle, polygon, or network cloud.

To change an annotation’s properties, such as border width and color, select the annotation, 
and then select Properties from the right mouse menu. 

Link Lines

In Map View, you can use Link lines to monitor the status of the network link (the Interface 
service) between two devices. Link lines can also show the status of any service which has 
an Active Monitor on the device. The following shows a map with link lines displayed.

Map View Annotation Toolbar
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• Router 1 shows a connecting link to device RRA and this link is currently up. Also 
shown are eight unconnected links, all of which represent interfaces on the router. One 
of the unconnected links is disabled.

• JMA is a workstation that shows two unconnected links that are currently up. If you 
look in Device Properties, Active Monitors, you'll see these are the Ping and FTP moni-
tors.

• RRA is an FTP Server that is currently down and shows five unconnected links, two of 
which are down. 

Links are rendered in the color of their device state:

• Green indicates a service (such as, but not limited to, "Interface") that is up. This 
includes services that have not yet been polled.

• Red indicates a service that is down.

• Gray indicates a service listed in the devices’ Active Monitors list, but not currently 
monitored.

• Orange indicates that the device is currently in maintenance mode.

How to Create Connecting Links

There are three ways to set up the connecting link lines:

• Manually, using Link to on the right-click menu for a device. (Disconnect link to 
remove them.)
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a Select a monitor for which you want to display a link line, then click OK. The link 
line cursor appears. 

b Move the cursor to another device and click to create a link.

• Automatically, during Device Discovery when using SNMP SmartScan. 

•  Automatically, when you click the Discover button in the Device Properties > Active 
Monitors dialog. These link lines are not connected to any other device.

To display unconnected link lines, right-click in the map view and choose Display > Uncon-
nected Links.

Attached Lines

Attached lines show an arbitrary connection between devices and move with the device. 
These are visual representations assigned by the user, and not reflections of true connectivity 
between the two devices; that is done with link lines (See “Link Lines” on page 44).

To draw an attached line:

1 In Map View, right-click a device to display the menu. 

2 Select Attach > Attach to. 

3 Click the device icon to which you want to attach a line. 

WhatsUp Professional draws an attached line between the two devices.

Note: The "Interface" service must be included in the scan.

When using one of the automatic Discover options, particularly when discovering 
interfaces on a router or switch, you need to enter the SNMP community string in the 
appropriate scan dialog. This allows the scan to identify all the interfaces on the device. 
If scanning a specific device (Device Properties > Active Monitors dialog), select the 
SNMP properties in device properties, select the SNMP manageable device option, 
and enter the Read community. Then, go to the Active Monitors dialog and click 
Discover.
When creating links manually, you are always creating a connected link. If there 
already was an unconnected link for that service, it will be replaced by the connected 
link.
Both connect and disconnect skips the dialog if there is only one active monitor on the 
device, as it assumes you meant that monitor. 

Note: The root device can attach to up to five other devices.
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Report View
Use the Report View to troubleshoot and monitor historical data that has been collected dur-
ing the operation of WhatsUp Professional. Reports can be viewed in the WhatsUp Profes-
sional console or the Web Interface, and they can be e-mailed on a regular basis to an e-mail 
address you identify through the Recurring Report feature.

For more information on the different reports that are available, see Chapter 7, Reports.
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Using the Web Interface 
Through the Web Interface, you can remotely configure your net-
work, just as if you were sitting at the WhatsUp Professional com-
puter and using the console. Although some of the navigation 
methods are different, the general functions and configuration pro-
cedures are identical. 

In addition, the Web interface can be used to let your entire IT staff 
take ownership of the monitoring of different sections of your net-
work, all using the same install of the WhatsUp Professional appli-
cation.

Connecting to the Web Interface

You can connect to the WhatsUp Professional Web interface from 
any browser by entering its Web address. This Web address con-
sists of the hostname of the WhatsUp Professional host and the 
Web server port number. The default port number is 80.  

For example, if your IP address of your WhatsUp Professional 
computer is 156.104.152.177, you would enter 
156.104.152.177:80 in your Web browser to connect to the inter-
face. 

The port number can be changed in the WhatsUp Professional con-
sole by selecting Tools > Program Options from the main menu. 
Select the General section and enter your new port number in the 
Enable web server on port box.

Access Problems

If you are having trouble connecting to the logon screen of the 
Web interface, you might want to make sure that there is no port 
conflict. Changing the port number as described above will fix that 
problem. Another common mistake is neglecting to enable the 
Web server itself. To enable the Web server, navigate to the What-
sUp Professional Console main menu, select Tools > Program 
Options.  Select the General section and select the Enable web 
server option.
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Default Logon

WhatsUp Professional comes with two default user accounts you can use to try out the appli-
cation. You should change these passwords as soon as you implement the application in a 
production environment. 

Web Interface Overview
The following is a breakdown of the main features found in the WhatsUp Professional Web 
interface.

1 Group/Device Operations. Select a link in this section to make changes to the current 
group or device, depending on what you have selected in the main pane.

2 View Selector. Choose the view you want to see the current group in. This option is not 
available when viewing device properties.

a List View. View the group as a list of devices. This is the view seen in the graphic 
above. 

Default Admin Account Default Guest Account

Username : admin 
Password: admin 

Username: guest
Password: (no password, leave blank)
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b Map View. View the group as a map file. You cannot make changes to the map in 
the Web interface. This has to be done in the WhatsUp Professional console. 

3 Group/Device Reports. Select a report from this list to view historical data for the 
selected group or device.

4 Main Pane. This is the main operating pane for the Web interface. Notice that when 
you are viewing a device group, you can click the device name in the list (or on the 
map) to access the device properties for that device.

5 Tab Bar. Select one of the three tabs to access that section of the Web interface.

a Explorer. Provides access to devices and device groups.

b Reports. Provides access to a variety of reports for the entire system, groups or 
specific devices.

c Configure.  Opens the System Configuration page, which allows you to change 
program options and define or edit Monitors, Actions, Devices and Notifications.

6 Group View Button Bar. When viewing a group in the list view, these buttons appear 
at the top and bottom of the device list. 

a Copy. Select a device or device group and click Copy to create copies of that 
device or device group in another device group. Multiple copies of the same device 
share the same database entry, so you only have to make changes to one copy for all 
of the devices to be changed. This also means that WhatsUp Professional only polls 
the device once, no matter how many device groups it appears in.

b Move.  Select a device or device group and click Move to move the items from the 
current group to another.

c Delete.  Select a device or device group and click Delete to remove those items 
from the current device group. If that device is the only entry in the database, the 
device will be removed from the database as well.

d Bulk Field Change. Select two or more devices or any number of device groups 
and click Bulk Field Change to make configuration changes to multiple device 
entries at once. For more information, see “Editing Multiple Devices - Bulk Field 
Change” on page 36.

e Acknowledge.  If a device name appears in bold in the device list, select that 
device and click Acknowledge to acknowledge that a state change has occurred. 
For more information on the Acknowledgement system,  see “Acknowledgements” 
on page 37.

7 When viewing devices and groups in the Explorer tab, a history of your path through 
the application is available.

8 This section displays the current user and a link to Log Out of the Web interface.
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Managing Web Users
The Web User Management system allows you to restrict access to your WhatsUp Profes-
sional Web interface to only those people who have an account set up through the interface. 
User permissions are configured for those users, limiting what operations they can perform 
throught the Web interface.

Access the User Management page by clicking Configure on the Tab bar and from the Sys-
tem Configuration page, select Manage Users. 

Click Add to create a new user, or click a user name to edit the settings for that user. The 
Edit/Create User page appears.
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• User Name. Enter the name of the user.

• Authentication Type. Select the method of authenticating the user.

• Internal. Use WhatsUp Professional's internal user database.

• LDAP. Use an external LDAP database. LDAP credentials must be configured for 
this to work.

• Internal Password. Enter the user's password (only if Authentication Type is set to 
Internal).

• Confirm Password. Enter the user's password again.

• Home Group. Select the device group that the user will see when they log into the 
WhatsUp Professional Web interface. If they have the correct group access rights, they 
will be able to navigate out of this group.

• Device Group Settings. (This section is only visible after a user has been created. After 
initial creation, you are prompted to set device group permissions.) Click Set Device 
Group Access Rights to make a change to the groups to which the user has read and 
write access.

• User Rights. Select which options to which you wish to give the user access. .

User Rights

The following rights can be given to a user:

• Manage Users. Create and edit users for use in the Web Interface.

• Manage IP Security. Allow or refuse access to the Web Interface to specific IP 
addresses.

• Configure Monitors. Configure active monitors for devices in the database.

• Manage Groups. Create, edit, or remove device groups, if the user has access to 
the groups.

• Access Group and Device Reports . View group and device reports for the groups 
to which the user has access.

• Access System Reports. View system reports.

• Configure LDAP Credentials. Allows user to configure LDAP credentials for the 
Web Interface. 

• Change Your Password. Allows users to change their own password.

Note: If you grant the Manage Group option, the Manage Device option is 
always selected as well.
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• Configure Actions. Create and edit actions in the Action Library.

• Manage Devices. Add new devices and edit existing devices in the groups to which  
the user has access.

• Manage Web Server. Change the configuration of the Web server.

Device Group Access Rights

You can further limit your Web users through Device Group Access Rights to only be able 
to view or manipulate certain device groups in your database. There are two ways to assign 
these rights: the first is by user and the second is by group. 

Assigning Access Rights by User

1 In the Manage Users dialog, select the user to whom you want to assign rights. 

2 In the Edit User dialog, click Set Device Group Access Rights. The page that appears 
shows all device groups in your database.

3 Select the group to whom you want to assign rights. 



55

CHAPTER 6Using the Web Interface

4 Select the rights you want to give to that user for the selected group. Click Apply 
changes to all sub device groups recursively to give these rights to all subgroups in 
the current group.

Assigning Access Rights by Group

1 In the Explorer tab of the Web interface, select the group to whom you want to assign 
rights.

2  In the Group Operations list, select Group Access Rights.

Select the user to whom you want to give current group access rights. Current rights 
appear in the user list next to the user's name.  

Note: Access rights will not be enforced until the Enforce Device Group Access 
Rights option is selected in Configure > Manage Web Server.
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3 Select the rights you want to give to that user for the selected group. Click Apply 
changes to all sub device groups recursively to give these rights to all subgroups in 
the current group.

Web Interface Operations and Device Group 
Access Rights

The following is a list of operations and the group access rights that must be assigned for the 
user to perform that task:

• List, Map, and Group reports in the Group Views menu require Group Read access.

• Create Group and Group Properties in the Group Operations menu require Group 
Read Write access.

• Copy Group requires Group Read in the source group, and Group Read Write in the 
destination group. (Permissions to groups and subgroups are copied, not inherited from 
the new parent).

• Move Group requires Group Read Write in both the source and the destination groups. 
(Permissions of the group and subgroups remain the same.)

• Delete Group requires Group Read Write, Device Read Write recursively. (Device Read 
Write may not be required if the group is empty).

• Create Device requires Group Read Write and Device Read Write. If the device already 
exists in other group(s), you must also have Group Read Write and Device Read Write 
in one or more of those groups.

• Copy Device requires Group Read in the source group and Group Read Write in the 
destination group. The level of device permissions must be the same in both groups. 
Downgrade from Device Read Write to Device Read is also permitted.

• Move Device requires Group Read Write in both the source and the destination groups. 
The level of device permissions must be the same in both groups. Downgrade from 
Device Read Write to Device Read is also permitted.

• Viewing Device Properties and Device Reports requires Device Read.

• Modifying Device Properties, Bulk Field Change, and Acknowledgement require 
Device Read Write.

Note: Access rights will not be enforced until the Enforce Device Group Access 
Rights option is selected in Configure > Manage Web Server.

Note: Access rights will not be enforced until the Enforce Device Group Access 
Rights option is selected in Configure > Manage Web Server.
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Manage Web Server
The following is a list of items that can be configured on your Web server. 

• Page Auto Refresh Frequency. Enter, in seconds, how often you want device list, map 
and report pages to reload and refresh their data.

• Enable Web server on port. Enter the port you would like the WhatsUp Professional 
Web server to use for standard connections. The default value is 80, but you can enter 
any port number (for example, if you are running WhatsUp Professional on a server that 
also has a public Web server, you will want to enter a different port).

• Enable SSL web server on port. Enter the port you would like the WhatsUp Profes-
sional Web server to use for SSL-secured connections. The default value is 443, but you 
can enter any port number.

• Session Timeout. Enter, in minutes, the amount of time passed after which WhatsUp 
Professional ends the session of an inactive Web user. 

• Enforce Device Group Rights. Select this option to enforce device group rights on 
Web users. If this is selected, users will only be able to view the device groups for which 
they have rights. Clear this option to allow user access to all groups.

• Restart Web Server. Click this button to restart the Web server.

Securing the Web Interface
Beyond the User Accounts, there are other security features included with the WhatsUp Pro-
fessional Web interface.
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• IP Security.  Specify an IP address or set of IP addresses that are either granted access 
to the Web site or are denied access. Addresses which are in both/neither the allow and 
deny lists are allowed.

• SSL. Use the SSL Web server to secure the information passed from the WhatsUp Pro-
fessional Web server to the computer that you are using to access the interface.

Configuring the Web Interface to use IIS
Follow these steps to run the WhatsUp Professional Web Interface through an IIS (Internet 
Information Server) Web server.

1 Allow MSDE to use SQL Server Authentication. Use Regedit.exe to set 
Software\Microsoft\Microsoft SQL Server\WHATSUP\MSSQLServer\LoginMode=2.

2 Restart the MSSQL$WHATSUP service.

3 Specify a username and password for WhatsUp Professional to use when connecting to 
MSDE. Run NmConfig.exe and specify user=sa and password=wug_sa. This is using 
the built-in account that was installed by the WhatsUp Professional installation. The 
user is free to specify any user, as long as they have proper rights on the WhatsUp data-
base. It is recommended that they at least change the sa password.

4 Make sure that IIS does not have any of the WhatsUp Professional COM objects or 
DLLs loaded. This can be done by restarting IIS.

A Note About Web Security

WhatsUp Professional is installed with the files needed to immediately begin 
connecting to the SSL Web server using 128-bit encryption. 

The files included with the install (root.pem and server.pem) are installed with every 
copy of WhatsUp Professional. Therefore, your encrypted session may not be as 
secure as it could be.

These certificate files are installed for demonstration purposes only, and should be 
replaced with certificates that you generate and sign. 

Furthermore, this sample certificate is issued with Ipswitch as the Common Name. 
This will always give a Domain Name Mismatch Security Error on every fresh browser 
session in your environment. 

These sample files reside in the <WhatsUp Professional Install Directory>\data\SSL 
directory and should be updated with your own files.
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5 Create a virtual directory in IIS named NmConsole which points to <install 
path>\HTML\1033\NmConsole. Go to Control Panel\Administrative Tools\Internet 
Information Services. Right-click on Default Web Site and choose New > Virtual 
Directory.

6 Use http://localhost/NmConsole to connect to the Web interface.
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Active Monitors
Active Monitors query network services installed on a device, then 
wait on the response. If a response is not received, or if the 
response does not match what is expected, the service is consid-
ered down, and a state change occurs on the device. If the query is 
returned with the expected response, the service is considered up. 

Monitors and Actions

The Monitors and the Action systems work together in WhatsUp 
Professional to help you stay informed about what is happening in 
your network and the devices connected to your network. It is a 
cooperative relationship that can be configured to go well beyond 
the default setting included with the installation of the product. 
With some helpful examples, and a touch of creativity, a network 
administrator should be able to tailor the Monitors and Actions 
systems to watch over all of their important devices, and to trou-
bleshoot problems that may arise.

Taking Advantage of the Relationship 

There are a few things to think about when setting up your Actions 
and Monitors. These will help you maximize the usefulness of the 
features, and minimize problems you may encounter. 

• Actions Coverage. Set up your notification actions so that 
only the people that have to be notified are sent the alert. Con-
sider creating vacation Action types that will not send alerts to 
people who can't do anything about it. 

• Understanding SNMP. It will take a little research, but when 
you find out which of your networked devices have SNMP 
capabilities, you can configure Monitors to listen for all sorts 
of information, and trigger an Action accordingly. 

• Security Features. Pay careful attention to your devices and 
services that are critical to the security of your network. 

• Network Resources. WhatsUp Professional can be config-
ured to perform an Action when your network resource avail-
ability diminishes across a certain threshold. 
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• Assigning Actions to Devices or Monitors. Assign actions to the device if you only 
want one notification when the device goes down. Assign an action to a specific Active 
Monitor if it requires special attention.

Active Monitor Library
The Active Monitor Library is the central storehouse of all Active Monitors that have been 
configured for your network. When changes are made to the Active Monitors listed in this 
dialog, those changes affect each instance of that particular monitor across your device 
groups.

Access the Active Monitor Library from the main menu of the WhatsUp Professional con-
sole. Select Configure > Active Monitor Library.

This dialog is used to configure new or existing Active Monitor types. The list shows all 
types currently configured for use in WhatsUp Professional. 

• Click New to configure a new type.

• Select an existing type and click Edit to change the current configuration of a type.

• Select an ActiveMonitor type and click Copy to make a copy of that type and add it to 
the list.

• Select an Active Monitor type and click Delete to remove it from the list.

• Select an Active Monitor and click Test to test the selected Active Monitor on a device.
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Supported Active Monitors

The following is a list of all of the Active Monitor types that are supported by WhatsUp Pro-
fessional.

• DNS Monitor. This is a simple service Monitor that checks for the DNS (Domain 
Name Server) on port 53. If no DNS service responds on this port, then the service is 
considered down.

• SNMP Monitor. Simple Network Management Protocol is the protocol governing net-
work management and monitoring of network devices and their functions. This monitor 
queries the SNMP device and tries to match the expected returned value.

• Telnet Monitor. This monitor checks for a Telnet server on port 23. If no telnet service 
responds on this port, then the service is considered down.

• Ping Monitor. This monitor sends an ICMP (ping) command to the device. If the 
device does not respond, the Monitor is considered down.

• TCP/IP Monitor. This monitor is used to monitor a TCP/IP service that either does not 
appear in the list of standard services or uses a non-standard port number. 

• NT Service Monitor. This monitor allows you to check the status of a service on an 
Windows machine and attempt a restart of that service (if the appropriate Administrator 
permissions exist).

Assigning Active Monitors
There are two steps in assigning an Active Monitor to a device. The first is to configure the 
Active Monitor in the Active Monitor Library, and the second is to add that Monitor to a 
device. For most users, the default configuration is enough, so there is no need to make any 
changes to the Active Monitors in the library.

Add/Edit an Active Monitor

1 From the main menu, select Configure > Active Monitor Library to view the Active 
Monitor Library.

Note: A running WMI service on the targeted machine is required for this NT 
Service Monitor to work properly. Windows 2000, XP, and 2003 are installed 
with the WMI (Windows Management Instrumentation) service. WMI is not 
installed with WhatsUp Professional, but WMI can be downloaded from 
Microsoft and installed on Windows NT. 
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2 Click New to configure a new Active Monitor, or select a Monitor from the list and 
click Edit to make changes to an existing configuration. The configuration dialog for 
that Monitor type appears.

3 Once you make the necessary changes, click OK to add the Monitor to the list, or to 
save the changes you made to one already on the list.

Assign an Active Monitor to a Device

There are three ways to add Active Monitors to devices:

• Selecting the Active Monitors you want to scan for during Device Discovery. When you 
select the discovered devices and add them to your database, WhatsUp Professional cre-
ates a Monitor for each network service found.

• Click the Discover button on the Active Monitor dialog of Device Properties. WhatsUp 
Professional will then scan the device and create a Monitor for each network service 
found.

• Manually assign an Active Monitor to the device:

a On the Active Monitor dialog of Device Properties, click Add. The Monitor Prop-
erties dialog appears.

b Select the Active Monitor type you want to assign. Click Next.

c Set the polling properties for the Monitor. Click Next.

d Setup actions for the Monitor. 

e Click Finish to add the Monitor to the device.

Deleting Active Monitors
Unless you are absolutely sure you need to remove an Active Monitor type from the Active 
Monitor Library, you should never have to delete an item from this list. If you do, and you 
find you need it later, you will have to configure it completely yourself. This includes the 
default types that were added during initial installation of WhatsUp Professional. It is rec-
ommended that you only delete the custom Monitors that you create. 

Warning: When you remove an Active Monitor type from the library, all Active Monitors 
of that type are deleted from the devices you are monitoring, and all related report data is 
lost.

The best course of action is to remove the Monitors at the device level. 



65

CHAPTER 7Active Monitors

To remove a Monitor from a device

1 Double-click the device from which you want to remove the Monitor. The Device 
Properties dialog appears.

2 Click the Active Monitor icon in Device Properties.

3 Select the Monitor you want to remove from the list.

4 Click Remove.

5 A warning dialog appears, stating that all data for that Monitor will be deleted if the 
Monitor is removed.

6 Click OK to remove the Monitor.

Note: If you wish to stop monitoring an Active Monitor on a device, but want to keep the 
historical data, then you must disable the monitor instead of delteting it from a device.
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Passive Monitors
Some elements on a network may not provide a clear up or down 
status when queried. For example, a message may get logged to the 
system's Event log by another application (such as an anti-virus 
application alerting when a virus is found). Since these messages/
events can occur at any time, a Passive Monitor Listener "listens" 
for them, and notifies WhatsUp Professional when they occur.

Configuring Passive Monitor 
Listeners

Passive Monitor Listener is a separate executable that listens for an 
event to occur and then notifies WhatsUp Professional. This lets 
you get notification of an event when it occurs - rather than polling  
for all event types. The Passive Monitor Listener is solely respon-
sible for how it monitors its events. This means that the server 
could listen for network traffic, file changes, or application specific 
events.

WhatsUp Professional is installed with three Passive Monitor Lis-
teners:

• SNMP Passive Monitor (SNMP Trap). A trap is an unsolic-
ited SNMP message sent from a device to indicate a change in 
status, such as a router indicating one of its interfaces went 
down or a printer indicating that it is out of paper.

• Syslog Passive Monitor.  A Syslog Monitor is used to exam-
ine Syslog messages forwarded from other devices for a spe-
cific record and/or specific text within a record. Usually 
Syslog messages are forwarded from the "Syslog" on a system 
that runs UNIX, but they can come from non-UNIX devices 
as well. They might contain anything that you want perma-
nently logged, such as a device failure, or an attempt to log in 
to the system.

• Windows Event Log Monitor. This could be monitoring 
when a service is started or stopped, if there was a logon fail-
ure, or any other entry in the Windows Event Log.
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Before you can configure Passive Monitors, you must configure these listeners.

1 From the WhatsUp Professional console main menu, select Configure > Program 
Options.

2 In Program Options, select Passive Monitor Listeners.

3 Select the listener you want to configure and click Configure.

4 Enter the appropriate information based on the listener being configured.

5 Click OK to save the changes.

Passive Monitor Library
This dialog displays the Passive Monitor types that have been created for WhatsUp Profes-
sional. These types are specific configurations of SNMP traps, Windows Log Events, and 
Syslog Events. Once the Monitor types have been configured, you can associate them to 
devices on the Passive Monitors section of Device Properties.

To access the Passive Monitor Library on the WhatsUp Professional console, select Config-
ure > Passive Monitor Library.

• Click New to create a new type.

• Select a type in the list and Click Edit to change the settings.

• Select a type and click Copy to create a new type based on the selected type.

• Select a type and click Delete to remove it from the list.
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Configuring Passive Monitors

Add/Edit a Passive Monitor Manually

1 From the main menu, select Configure > Passive Monitor Library to view the Passive 
Monitor Library.

2 Click New to configure a new Passive Monitor, or select a Monitor from the list and 
click Edit to make changes to an existing configuration. The configuration dialog for 
that Monitor type appears.

3 Once you make the necessary changes, click OK to add the Monitor to the list, or to 
save the changes you made to one already on the list.

Assign a Passive Monitor to a Device

1 On the Passive Monitor dialog of Device Properties, click Add. The Passive Monitor 
Properties dialog appears.

2 Select the Passive Monitorand type you want to assign. Click Next.

3 Set up Actions for the Monitor. 

4 Click Finish to add the Monitor to the device.
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Using TrapImport.exe to Create Passive Monitors

This application imports the information in traps.txt and into the WhatsUp Professional 
database. When the process is complete, all traps defined in the file appear as SNMP Passive 
Monitors in the Passive Monitor Library. The traps.txt and mib.txt files are created or 
updated when you run mibextra.exe on the MIB files supplied by the manufacturer of your 
SNMP devices.

While mib.txt is not directly used by trapimport.exe, it is used to give meaning to the infor-
mation found in traps.txt. TrapImport.exe stores the OID (Object ID) name from Traps.txt in 
the database, for example, "cisco" or "snmp". However, in order for SNMP Passive Moni-
tors to work, a lookup is performed on mib.txt that converts the OID name to numeric OID. 
For this to work properly, both files must be in the WhatsUp Professional program directory.

To execute TrapImport.exe, run the executable in the command line.

TrapImport.exe is also called by the WhatsUp Gold Data Migration utility during the migra-
tion process. This utility automatically copies your WhatsUp Gold mib.txt and traps.txt into 
the WhatsUp Professional program directory.

Note: Traps.txt must exist in the default install directory. If you move TrapImport.exe and 
the traps.txt file to another folder, TrapImport.exe ignores the moved file and still looks 
in the default install directory for that file.



9
Chapter

71

Reports
In WhatsUp Professional, reports are used to troubleshoot and 
monitor historical data that has been collected during the operation 
of the application. Reports can be viewed in the console or the 
Web Interface, and they can be e-mailed on a regular basis to an e-
mail address you identify through the Recurring Report feature. 

Collecting Statistical Data

By default, performance statistics are not kept for the Monitors 
assigned to the devices in your database. When viewing a report 
for these Monitors, you will see the following phrase in the perfo-
mance graph:

There are two ways to start collecting this data. 

• Click on the link in the center of the performance graph to 
access the Configure Statistics Gathering page. Select the 
option that best suits your needs. 

If you select Inherit from device settings, you must turn 
gathering on in Device Properties. This is described in the 
section below.

 

In this Chapter

Setting Up FTP Hosts

Adding Additional FTP Hosts

Configuring an External User 
Database

Configuring an NT User 
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Setting Options for the FTP 
Host

Renaming an FTP Host
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Report List

Recurring Reports

Creating Custom Reports
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• Access Device Properties > Polling for the device on which you want to begin collect-
ing statistical data. 

• Select  the Collect Active Monitor statistical data for reports option. This turns gath-
ering on for all Monitors associated to this device. You can turn them on or off individ-
ually by following the instructions in the first bullet point.

Report List
The following is a list of all reports that are available in WhatsUp Professional.

System Reports

Activity Log The Activity Log report is a categorized history of all 
messages generated by WhatsUp Professional for 
the time period displayed at the bottom of the report.

Syslog Entries This report shows syslog events logged during the 
time period displayed at the bottom of the report. 

SNMP Trap Log The SNMP Trap Log provides a history of SNMP 
traps that have occurred during the time period 
displayed at the bottom of the report.  If the SNMP 
Trap Passive Monitor Listener is configured to listen 
for messages, any messages received are recorded 
in the SNMP Trap Log.

Windows Event Log This report shows Windows events logged for all 
devices during the time period displayed at the 
bottom of the report.
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Actions Applied The Actions Applied report shows how Actions are 
applied to devices and Monitors in the system.  
Each entry shows an action and the device, Monitor 
and state that triggered it.

Active Discovery Log The Active Discovery log shows the results of all 
Active Discovery tasks that are configured in 
WhatsUp Professional. This log shows the general 
result of the task, but does not show the devices 
and services that were discovered. You must 
access the Active Discovery Results report to 
process the discovered items.

Active Discovery Results Once an Active Discovery task discovers new 
devices or services, this report is populated with the 
results of that scan. 

State Change Acknowledgement When a device state changes, regardless of any 
action that has been placed on the device,  
WhatsUp Professional uses the Acknowledgement 
feature to make you aware that the state change 
occurred. In the Device List, the name of the device 
appears in bold, and in the Map View, the device 
name appears on a black background. 

Action Log The Action Log shows all Actions that WhatsUp 
Professional has attempted to fire, based on the 
configuration of the action. 

General Error Log The General Error log shows a list of error 
messages generated by WhatsUp Professional for 
the desired time period. 

Passive Monitor Error Log This report shows all Passive Monitor errors that 
occur during the operation of WhatsUp 
Professional.

Recurring Report Log This report shows a log of all recurring reports that 
have occurred during the selected time period. 

Group Reports

State Summary This report is a summary of device states in the 
current selected group. 

Availability This report displays a percentage of time that each 
monitored device in the selected group has been Up 
and responding to polls during the displayed time 
period. The time period can be found at the bottom 
of the report.

Health This report displays the current status of monitored 
devices in the selected group, along with each 
Monitor configured to those devices.
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Saving a Report

Using Windows Internet Explorer, you can save a report for later viewing. 

Performance This report shows the response time of each device 
in the group.  The graph displays the responses over 
the time period displayed at the bottom of the report.

State Change Timeline This report shows a timeline of when each Monitor 
on a device in the selected group changed from one 
state to another during the displayed time period.  
The time period can be found at the bottom of the 
report.

Actions Applied The Group Actions Applied report shows how 
Actions are applied to devices and Monitors in the 
current group. Each entry shows an action and the 
device, Monitor and state that triggered it.

Device Reports

Availability This report shows statistics about the availability of 
the selected device.

Health This report displays the current status (a snapshot) 
of the selected device and all Monitors on that 
device. Each Monitor shows its own device state, 
the current status of each item, how long the device 
has been in that status, and the time that status was 
first reported. 

Performance This report shows the average response time of 
each Monitor attached to the selected device.  

State Change Timeline This report shows a timeline of when each Monitor 
on the selected device changed from one state to 
another during the displayed time period.  The time 
period can be found at the bottom of the report.

Syslog Entries This report shows syslog events logged for the 
selected device during the time period displayed at 
the bottom of the report. 

SNMP Trap Log The SNMP Trap Log provides a history of SNMP 
traps that have occurred for the selected device 
during the time period displayed at the bottom of the 
report.  If the SNMP Trap Passive Monitor Listener 
is configured to listen for messages, any messages
received are recorded in the SNMP Trap Log.

Windows Event Log This report shows Windows events logged for the 
selected device during the time period displayed at 
the bottom of the report.
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To do this, open the report through the Web interface, then select File > Save As in Windows 
Internet Explorer. Save the file as an .mht (Web Archive, single file) file.

Recurring Reports
Through this feature, you can configure WhatsUp Professional to send reports to e-mail 
addresses at regularly scheduled intervals. Each entry represents a different e-mail address 
or report that is to be sent. 

• Click New to create a new recurring report.

• Select an entry and click Edit to make changes that entry. 

• Select an entry and click Copy to create a copy of that entry. You can then edit the new 
copy as needed.

• Click Delete to remove a recurring report.

• Select an entry and click Test to test the recurring report.

Creating Custom Reports
In WhatsUp Professional, you have the ability to create customized reports to display infor-
mational and historical data about your network and the devices you are monitoring through 
the application. To create these reports, you should be experienced with ASP, JScript, and 
SQL and have the means to identify the database entries you want to write into the parame-
ters of the report. 
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Follow these steps to create a custom report and have that report appear in the lists and 
menus in the application, based on the report type you assign:

1 Add the report to the Report database table.

2 Open the Custom Report Template.

3 Add custom report content to the template.

4 Save the new report file in the WhatsUp Professional Reports directory.

Step 1 - Add the report to the Report database table.

Once the report entry is in the database, the report name appears in the report pull-down 
menu in the Report view of the console, and in the report lists throughout the application. 
Without this entry, you will not be able to test the report as you create it.

Step 2 - Open the Custom Report Template

Download the Custom_Report_Template.asp file from the Solutions Guide at http://
www.ipswitch.com/support/whatsup_professional/guides/index.asp and open it, or copy the 
text below and paste it into an HTML or text editor. 

Simple Custom Report Template

<%@ language="jscript" %>
<!--#include file="../StandardIncludes/
ApplicationContext.inc" -->
<!--#include file="../utility/Sql.inc"-->
<!--#include file="SelectReport.inc"-->
<!--#include file="../StandardIncludes/Header.inc"-->
<%= app.GetReportHeader("CustomReport.asp", "Custom Report 
Title",  "icnChartPie32.gif") %>

nReportID Identity column. This is assigned by the 
database.

sName Enter a name for the report.

sDescription Enter a description of the report.

sFilename The file name of the report, relative to the 
Reports directory.

nReportType An integer value. Valid report types:
1 = Device Reports
2 = Group Reports
3 = System Reports
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Report Content

<%= app.GetReportFooter() %>
<!--#include file="../StandardIncludes/Footer.inc"-->

Include File Descriptions

The following describes the include files that appear in the Custom Report Template.  To 
make sure the report looks and functions like the default reports, these includes, and the 
commands calling them must remain unchanged. 

The code for the includes assume the default install directory structure. All of the calls use 
the following as the root directory:

<<Install directory>>\HTML\1033\NmConsole\

ApplicationContext.inc

This include defines the functions that appear below: 

app.GetReportHeader(sFilename, sTitle, sIconName)
Returns an HTML string that opens the report table.

sFilename = The report filename as it appears in the 
database.
sTitle = The title of the report.
sIconName = The report icon relative to the Reports/Images 
directory.

app.GetReportFooter()
Returns an html string that closes the reports table. 

app.GetDeviceID()
Returns the device ID currently in context. 

app.GetDeviceGroupID()
Returns the device group ID currently in context.

app.SetScreenTitle(sTitle, sTab, bAutoRefresh)
Sets the title of the current page.

sTitle = The title of the page.
sTab = The selected tab. For reports this is best set to 
null.
bAutoRefresh = Set to true if you wish the report to 
refresh.



78

CHAPTER 9 Reports

Sql.inc

ExecSQL(sCommandText)

Executes a specified query, SQL statement, stored procedure, or provider-specific 
text.

The results are stored in a new Recordset object if it is a row-returning query. A 
closed Recordset object will be returned if it is not a row-returning query. 

Note: The returned Recordset is always a read-only, forward-only Recordset!

SelectReport.inc

Including this file gives the app.GetReporHeader(…) function the ability to display the 
report select combo box.

Header.inc & Footer.inc

The header include provide standard <html> and <body> tags. The footer include closes 
these tags.

Step 3 - Add custom report content to the template.

The report is a product of the device or group context and the SQL commands necessary to 
retrieve data from the database. The context makes sure that the device or group you are try-
ing to run the report against is the correct one. System reports do not require the context.

Insert the following ASP code as needed.

Group Reports

The following shows how to obtain a group name for the report header.

<%
var nDeviceGroupID, oGroupInfoRS, sGroupName
nDeviceGroupID = app.GetDeviceGroupID();
oGroupInfoRS = ExecSQL(

"SELECT DeviceGroup.sGroupName FROM DeviceGroup "
+ " WHERE DeviceGroup.nDeviceGroupID = " 
+nDeviceGroupID
);

if(oGroupInfoRS.EOF) ValidateDeviceGroup(true, 
app.REPORT_TYPE_GROUP);
sGroupName = oGroupInfoRS.Fields("sGroupName")+"";
oGroupInfoRS.Close();
app.SetScreenTitle("Custom Report for Group " + sGroupName, 
null, true);
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%>

The ValidateDeviceGroup() function is included with :

<!--#include file="../utility/StandardFunctions.inc"-->
This function insures that the device group in context is a valid device group. If it is not, 
then the method will display an error message and intelligently redirect the user.

The html code to display the group in context:

<table cellpadding="0" cellspacing="0" border="0" 
class="contentTbl">

<tr>
<td class="content-headerCell">

Current Group :
<%= sGroupName %>
<%= GetGroupSelectorLink() %>

</td>
</tr>

</table>

The GetGroupSelectorLink() function is included with :

<!--#include file="../utility/ReportsStandardFunctions.inc"--
>

This function displays a link to be able to select a different group.

Device Reports

<%
var nDeviceID, oDeviceInfoRS, nDeviceTypeID, sDeviceName, 
nWorstSTateID;
nDeviceID = app.GetDeviceID();
oDeviceInfoRS = ExecSQL(

"SELECT sDisplayName, nDeviceTypeID, nWorstStateID 
FROM Device "
+ "WHERE nDeviceID = " + nDeviceID + " AND 
ISNULL(bRemoved, 0) = 0"
);

if(oDeviceInfoRS.EOF) ValidateDevice(true, 
app.REPORT_TYPE_DEVICE); nDeviceTypeID = 
parseInt(oDeviceInfoRS.Fields("nDeviceTypeID"));
sDeviceName = oDeviceInfoRS("sDisplayName") + "";
nWorstStateID = parseInt(oDeviceInfoRS("nWorstStateID"));
oDeviceInfoRS.Close();
app.SetScreenTitle("Custom Reoprt for Device " + 
sDeviceName, null, true);
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%>

The ValidateDevice() function is included with :

<!--#include file="../utility/StandardFunctions.inc"-->
This function insures that the device in context is a valid device. If it is not, then the method 
will display an error message and intelligently redirect the user.

The GetReportsMonitorDeviceStateIconLarge() and GetDeviceSelectorLink() functions 
are included with :

<!--#include file="../utility/ReportsStandardFunctions.inc"--
>

GetReportsMonitorDeviceStateIconLarge() gets the image src for the device icon. This 
is used below in the section Getting the State Icon. GetDeviceSelectorLink() displays a 
link to be able to select a different device.

The html code to display the device in context:

<table cellpadding="0" cellspacing="0" border="0">
<tr>

<td class="content-headerCell">
<%= sDeviceName %>
<%= GetDeviceSelectorLink() %>

</td>
</tr>

</table>

The GetDeviceSelectorLink() function is included with :

<!--#include file="../utility/ReportsStandardFunctions.inc"--
>

This function displays a link to be able to select a different device.

Getting the State Icon

If you need to display the state icon in the report, add this code to the report content.

<%
var sDeviceImageSrc =  
GetReportsMonitorDeviceStateIconLarge(

nWorstStateID,
nDeviceTypeID,
"FFF8DC"
);

%>
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Insert the following HTML where you want the device icon to appear on the report:

<img src="<%= sDeviceImageSrc %>" align="absMiddle">

SQL Commands

SQL commands are used to pull data from the database and display it in the report. Write 
these commands and place them in the report after the context is declared.

Step 4 - Save the new report file.

Once the report is complete, save it as an .asp file using the filename added to the database in 
step 1. The default path to the report directory is:

 <<Install directory>>\HTML\1033\NmConsole\Reports

Sample Report

The following is a sample report that you can use to familiarize yourself with the commands 
and functions of the reporting system. The report itself displays general device properties of 
the device that is put in context by the application. 

<!--
Sample Device Details Report
Enter this into the WhatsUp database Report table:
sName : Sample Device Report
sDescription : Device details sample report
sFilename : _sampleDeviceReport.asp
nReportType : 1

//-->
<!--
This section is from the template
//-->
<%@ language="jscript" %>
<!--#include file="../StandardIncludes/
ApplicationContext.inc" -->
<!--#include file="../utility/Sql.inc"-->
<!--#include file="SelectReport.inc"-->
<!--#include file="../utility/StandardFunctions.inc"-->
<!--#include file="../utility/ReportsStandardFunctions.inc"--
>
<%
// This section places the device in context.
var nDeviceID, oDeviceInfoRS, nDeviceTypeID, sDeviceName, 
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nWorstSTateID;
nDeviceID = app.GetDeviceID();
oDeviceInfoRS = ExecSQL(
"SELECT sDisplayName, nDeviceTypeID, nWorstStateID FROM 

Device "
+ "WHERE nDeviceID = " + nDeviceID + " AND ISNULL(bRemoved, 

0) = 0"
);

if(oDeviceInfoRS.EOF)
ValidateDevice(true, app.REPORT_TYPE_DEVICE);

nDeviceTypeID = 
parseInt(oDeviceInfoRS.Fields("nDeviceTypeID"));
sDeviceName = oDeviceInfoRS("sDisplayName") + "";
nWorstStateID = parseInt(oDeviceInfoRS("nWorstStateID"));
oDeviceInfoRS.Close();
app.SetScreenTitle("Details for Device " + sDeviceName, null, 
true);

//This section gets the state change icon.
var sDeviceImageSrc =  GetReportsMonitorDeviceStateIconLarge(
nWorstStateID,
nDeviceTypeID,
"FFF8DC"
);

//This section contains the SQL commands written for the 
report.
var sSQL = "Select "
+ "Device.sDisplayName, "
+ "DeviceType.sDisplayName AS sTypeName, "
+ "sNetworkName, "
+ "sNetworkAddress, "
+ " sNote "
+ "FROM Device "
+ "INNER JOIN NetworkInterface ON 

NetworkInterface.nNetworkInterfaceID = 
Device.nDefaultNetworkInterfaceID "
+ "INNER JOIN DeviceType ON DeviceType.nDeviceTypeID = 

Device.nDeviceTypeID "
+ "WHERE Device.nDeviceID = " + app.GetDeviceID();
var oDeviceRs = ExecSQL(sSQL);

%>
<!--#include file="../StandardIncludes/Header.inc"-->
<!-- More from the template
//-->
<%= app.GetReportHeader("_sampleDeviceReport.asp", "Device 
Details Report",  "icnChartPie32.gif") %>
<!-- This section controls the formatting of the data as it 
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appears on the report page itself, after it has been 
generated.
//-->
<table cellpadding="0" cellspacing="0" border="0" 
class="contentTbl">
<tr>

<td class="deviceReportCell">
<table cellpadding="0" cellspacing="0" border="0">

<tr>
<td><img src="<%= sDeviceImageSrc %>"
 align="absMiddle"></td>
<td class="content-headerCell">

<%= sDeviceName %>
<%= GetDeviceSelectorLink() %>

</td>
</tr>

</table>
</td>

</tr>
<tr>

<td  class="deviceReportCell">
<table cellpadding="0" cellspacing="0" border="0">

<tr>
<td valign="top" align="right">Device Name:
</td>
<td><%= oDeviceRs("sDisplayName") %></td>

</tr>
<tr>

<td valign="top" align="right">Device type:
</td>
<td><%= oDeviceRs("sTypeName") %></td>

</tr>
<tr>

<td valign="top" align="right">Network name:
</td>
<td><%= oDeviceRs("sNetworkName") %></td>

</tr>
<tr>

<td valign="top" align="right">Network 
address:</td>
<td><%= oDeviceRs("sNetworkAddress") %></td>

</tr>
<tr>

<td valign="top" align="right">Note:</td>
<td>

<% var sNote = oDeviceRs("sNote")+""; %>



84

CHAPTER 9 Reports

<%= sNote.replace(/(\r\n|\r|\n)/g,'<BR>') %>
</td>

</tr>
</table>

</td>
</tr>

</table>
<!-- The rest is from the template
//-->
<%= app.GetReportFooter() %>
<%
oDeviceRs.close();
%>
<!--#include file="../StandardIncludes/Footer.inc"-->
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Actions
Actions provide the mechanism for notifying you about changes in 
the status of a device or a Monitor, or for launching a program in 
response to a status change. For example, if your Web server 
device is down, you will get a visual indicator (the device icon 
changes color to red). You may also want to trigger an Action that 
plays a sound or sends an e-mail message to the Webmaster.

Action Library
The Action Library is the central storehouse of all Actions that 
have been configured for your network. When changes are made to 
an Action listed in this dialog, those changes effect each instance 
of that particular Action across your device groups.

To open the Action Library, from the main menu of the WhatsUp 
Professional console, select Configure > Action Library.

This dialog is used to configure a new or existing Action.

In this Chapter

Action Library

Action Types

Action Strategies

Using Actions - A Simulation

Action Policies

Using Other Types of Actions

Percent Variables
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• Click New to configure a new Action. Then, select the Action Type. For a description of 
each type, see “Action Types” on page 86.

• To change the configuration of an Action, select it, then click Edit.

• To create a new Action based on the existing one, select an existing Action, then click 
Copy.

When you first open the Action Library, if you have not yet defined an Action, you will see 
the default Sound Actions, which you can assign to any device or Monitor.

Some Actions, when triggered, send a message (for example, e-mail, pager, SMS). You are 
provided with a default message for these Actions, which you can modify as needed. 

Once created, Actions can be assigned to a device, a Monitor, or included in an Action 
Policy. When you assign the Action to a device or Monitor, you specify the state change that 
will trigger the Action.

For a step-by-step example of how to create and assign an Action, see “Using Actions - A 
Simulation” on page 87.

Action Types
An Action assigned to a device or Monitor “fires” when a specified state change occurs. 
WhatsUp Professional supports the following types of Actions. 

• Sound: Sound an alarm by playing a selected sound file on the WhatsUp Professional 
console.

• Beeper: Activate a beeper.

• Pager: Send a message to a pager.

• E-mail: Send an SMTP Mail message.

• SMS: Send a Short Message Service (SMS) notification to a pager or cell phone.

• Winpopup: Display a message in a pop-up window on a Windows NT system.

• Syslog: Send a message to a host that is running a Syslog server.

• Text-to-Speech: Send a text-to-speech notification to a speaker.

• Program: Run another program (executable) to take some action.

• Service Restart: Stop or restart a Windows NT Service.

• Action Policy: Send a group of Actions that includes any of the above types.
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Action Strategies
When configuring Actions for your devices and Monitors, there are a few things you should 
take into consideration.

• Large lists of devices have the potential of sending out very large amounts of external 
notifications (for example, an e-mail, SMS, or pager message sent to inform the target 
of a state change).

Imagine the number of messages sent if external notifications are placed on a router and 
every device and monitor that uses that router for their connection to the Internet. If the 
router goes down, it will appear as if all of the devices are down, and messages will be 
sent for each of them. Consider using dependencies and limiting the external 
notifications to the router and the most important of the devices in the group.

• Don't rely on sound Actions when there is not someone around to hear the notification.

Sound notifications are safe to use in almost any situation, but is not the best choice for 
items that need to be monitored overnight.

• If the device states do not fit what you need, change them, or add new ones.

You may want to add device states for longer periods of downtime. For example, you 
could create a Down at least 60 mins state, and sending an escalated message to show 
that the device is still down after an hour.  

• Action Policies are easier to manage than lists of Actions built on a device.

Whenever possible, it is a good idea to use Action Policies over Actions configured for 
a single device. That way, you can reuse the work you put into the list, and can keep 
better watch over the Actions that are being fired.

• Visual notifications are usually enough for most of the devices on your network.

Unless the device is vital to the operations of the business or office, the state change 
color and shape should be enough to let you know what is going on with your monitored 
devices.

Using Actions - A Simulation
This section describes how to configure an Action and assign it to a device, using the 
example of an E-mail Action.

In the example, you want to be notified by e-mail if the web server device (the computer on 
which the web server is running) is down. To accomplish this, we will:

• Configure an E-mail Action

• Test the Action
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• Assign the Action to the device

Configure the Action

In this example, we are configuring an E-mail Action that will be assigned to a Web server 
device. If the device does not respond to polling for 2 or more minutes, the E-Mail Action is 
triggered and sends a message to the Webmaster.

1 Select Configure > Action Library.

2 Click New, then select E-Mail Action as the type. The New E-Mail Action dialog 
appears, with focus on the Mail Destination tab.

3 In the Name box, enter a unique name that identifies the Action, for example “Mailto 
Webmaster.” This name will be used to label the Action in other dialog boxes.

4 In the Description box, enter a short description of the Action. This is displayed in the 
Action Library along with the entry in the Name box.

5 In the SMTP Server box, enter the IP Address (or the DNS hostname) of the e-mail 
server for your domain. Port 25 is the standard port for SMTP communications; if your 
mail server uses a different port number, you can enter it in the Port box.

6 In the Mail to box, enter one or more e-mail addresses that are acceptable to your 
SMTP server. Separate each address with a comma; spaces are not allowed. The 
addresses should not contain brackets, braces, quotes, or parentheses.
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7 Select the Mail Content tab (at the top of the dialog) to switch focus.

8 The From address defines the sender of the message as:
 
WhatsUpPro@YourDomain.com. 

You can change YourDomain to your company’s domain name, or you can enter any 
address acceptable to your e-mail server.

9 The Subject box shows a status message that states the type of device, its current state, 
and the hostname.

%Device.Type is %Device.State (%Device.HostName) 

This message uses variables to show the type of device, its current state, and its 
hostname; for example: Server is down (Web1.YourDomain.com). 

You can use variables to customize the message in the Subject and in the Message Body.  
For more information on variables, see “Percent Variables” on page 96.

10 The Message Body box shows a detailed status message for the device. 

%Device.DisplayName is %Device.State on %Device.Type: %Device.HostName 
(%Device.Address)
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Details:

%Device.Attributes.Location

----------------------------------------

This mail was sent on %System.Date at %System.Time

Ipswitch WhatsUp Professional 2005

In our example, when the Action is triggered, the e-mail will report a message like the 
following:

Web1 is down on server:  web1.YourDomain.com (156.21.50.4)

Details:

Lamar Bldg; 2nd floor

-------------------------------------------

This mail was sent on 02/17/2005 at 15:34:06

Ipswitch WhatsUp Professional 2005

You can customize this message by adding or removing variables and text. For more 
information on variables, see “Percent Variables” on page 96.

11 Click OK to save the new Action.

The Name and Description of this Action now appears in the Action Library.

Test the Action

To test the Action, select it in the Action Library, then click the Test button. WhatsUp 
Professional runs a test and responds with a Success or Fail message. This test verifies the 
information specified in the Action. For example, for an E-Mail Action, it verifies that the 
SMTP Server is accessible and will accept a message from the specified user account.
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.

Note that this test is run by the WhatsUp Professional console (NMConsole.exe), but when 
an Action is triggered, it will be run by the service (NMService.exe). The best way to get 
accurate test results is to run both of these programs from the same Windows NT account.

1. Select the Action.

2. Click Test.

A message dialog 
shows the test results.
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Assign the Action to the Device

The next step in configuring an Action is to assign it to a device or Monitor. In our example, 
we assign the MailtoWebmaster Action to the Web1 device. If Web1 goes down, the Action 
sends an e-mail to the webmaster.

1 In the Device List, select the Web1 device, then right-click and select Properties from 
the menu. The Device Properties appear.

2 Select the Actions properties.

There are currently 
no Actions assigned 
to this device.



93

CHAPTER 10Actions

3 Select Apply individual Actions, then click Add. The Action Builder wizard appears. 

4 Select Select an Action from the Action Library, then click Next. 

5 Select the MailtoWebmaster Action, then select to trigger this action when the web 
server has been Down at least 2 min.

6 Click Finish to assign this Action to the Web1 server.

The Action is now shown on the Action properties for the device.

When the Web1 device is down for more than 2 minutes, the Action sends an e-mail 
message similar to the following:

 Web1 is down on server:  web1.YourDomain.com (156.21.50.4)

Details:

Lamar Bldg; 2nd floor



94

CHAPTER Actions

-------------------------------------------

This mail was sent on 02/17/2005 at 15:34:06

Ipswitch WhatsUp Professional 2005

Assigning an Action to a Monitor

You can also assign an Action to an Active or Passive Monitor. For example, you might 
create an Active Monitor to monitor the HTTP service on your Web server. Thus, you could 
know if the Web service went down, which may or may not mean that the Web server device 
is down.

Using our Web1 device example, we assign the MailtoWebmaster action to the HTTP 
Active Monitor:

1 In the Device List, right-click the Web1 device, then select Properties from the menu.

2 Select the Active Monitor properties.

3 Select the HTTP Monitor, then click Edit. The Monitor Properties appears.

4 Select Apply individual actions, then click Add. The Action Builder appears.

5 Select Select an action from the Action Library, then click Next.

6 Select the MailtoWebmaster action, then select it to execute on Down at least 2 min-
utes, then click Finish.

The Action is now shown in the Action properties of the Active Monitor.

7 Edit the content of the MailtoWebmaster action so it reports the Active Monitor status. 
Add the following text and variables to the message body:

Monitors that are down include: %Device.ActiveMonitorDownNames

Monitors that are up include: %Device.ActiveMonitorUpNames 

When the HTTP Active Monitor (on Web1) is down for more than 2 minutes, the Action 
sends an e-mail message similar to the following:

Web1 is down on server:  web1.YourDomain.com (156.21.50.4)

Monitors that are down include: HTTP Active Monitor

Monitors that are up include: 

Details:

Lamar Bldg; 2nd floor

This mail was sent on 02/17/2005 at 15:34:06

Ipswitch WhatsUp Professional 2005
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Action Policies
Action Policies let you stack multiple Actions together in a single Policy. You can then 
assign those Actions to any device. Once assigned, you can edit the Policies in the Action 
Policies dialog without having to make changes to all of the devices that use that particular 
Action.

To create an Action Policy:

1 From the menu bar, select Configure > Action Policies. The Action Policies dialog 
appears. 

2 On the Action Policies dialog, click New. 

3 In the New Action Policy dialog, enter a name in the Policy name box.  This name is 
used to identify the Policy later, so you should make sure the name is something that 
will help you remember what is contained in that policy.

4 Add existing Actions to the Action Policy, or create new Actions, then add them.

Click Add. The Action Builder wizard appears.

5 Follow the directions in the wizard.

6 Click Finish at the end of the wizard to add the Action to the policy.

7 Add as many Actions as you need to complete the Policy. You can move Actions up and 
down in the list by clicking the Up and Down buttons above the Action list.

8 Once all of the Actions have been added, click OK to create the Policy and add it to the 
active list.  

9 Assign the Action Policy to a device or monitor.

Using Other Types of Actions
Our simulation showed how to create an E-mail Action, test it, and apply it to a device. You 
would follow basically the same process if you wanted to use any of the other Actions. 
Actions like beeper, pager, sound, and WinPopup are similar to the E-mail Action we just 
covered. See the Help system for step-by-step procedures on creating these Actions. Some 
Actions may be used in other ways, which are briefly explained below:

• SMS Actions: You can send a message using SMS (Short Message Service). SMS is 
similar to paging. However, SMS messages do not require the mobile phone to be active 

During Device Discovery, you can assign an existing Action Policy (if one 
has been created previously), create a simple Action Policy through a wizard, 
or access the Action Policy Editor to create an Action Policy yourself.
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and within range and will be held for a number of days until the phone is active and 
within range. SMS messages are transmitted within the same cell or to anyone with 
roaming service capability.

• Service Restart: You can start or stop an NT service when another device or a Monitor 
does not respond to polling. Example: You can monitor a device’s Web server using 
HTTP. If it goes down, WhatsUp Professional can start a backup Web server (as an NT 
service). 

• Program: You can define Program Actions to launch an external application when a 
device goes down or comes back up. Example: You may have a “Trouble Ticket Sys-
tem” that you want WhatsUp Professional to interface with. This system logs trouble 
tickets for a network technician. When a device goes down, this notification executes a 
program that will log a trouble ticket. 

• Syslog: When a device does not respond to polling, you can send a Syslog message to a 
host that is running a Syslog server.

• Text to Speech: You can send a speech notification when a device does not respond to 
polling. This notification will audibly alert you via a speaker using a computer-gener-
ated voice.

Percent Variables
When an Action is triggered, a message (or command) is sent either to a person or to another 
program. Use the message variables (percent variables) to specify what information should 
be in the message. 

For example, the default e-mail message reports the following information: 

In the Subject line:

%Device.Type is %Device.State (%Device.HostName).

In the Message Body:

%Device.ActiveMonitorDownNames is %Device.State on %Device.Type: 
%Device.HostName (%Device.Address).

Details:

Monitors that are down include: %Device.ActiveMonitorDownNames

Monitors that are Up include: %Device.ActiveMonitorUpNames

WhatsUp Professional transmits the SMS message to the Provider, and the 
provider forwards it to the cell phone. WhatsUp Professional does not 
broadcast SMS messages directly.
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Notes on this device (from device property page):

%Device.Notes

----------------------------------------

This mail was sent on %System.Date at %System.Time

Ipswitch WhatsUp Professional 2005

You can customize a message by adding any of the variables in the following table.

% Variable  Description

%Device.Attribute Info Line 1 Device properties. 

Append the category to the end of the variable. 

Example: %Device.Attribute.Contact

Default categories:
• * -  Returns all attributes

• Info1 - Upgrade path from v8

• Info2 - Upgrade path from v8

• Contact - Contact info from SNMP.

• Location - Location info from SNMP

• Description - Description info from SNMP

%Device.Address The IP address from Device properties.

%Device.Type Device Type (from General of Device properties)

%Device.HostName Host Name (from General of Device properties)

%PassiveMonitor.DisplayName The name of the Monitor as it appears in the Passive 
Monitor Library.

 %PassiveMonitor.LoggedText Detailed Event description. (SNMP traps - Returns the full 
SNMP trap text.) (Windows Log Entries - Returns 
information contained in the Windows Event Log entries.) 
(Syslog Entries - Returns the text contained in the Syslog 
message.)

%PassiveMonitor.Payload.* Payload generated by a Passive Monitor.
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%PassiveMonitor.Payload.EventType The type of Passive Monitor (Syslog, Windows Event, or 
SNMP Trap)

See the definition in Help

%Device.Notes Notes. (Notes are from the Device properties Notes).

%Device.DatabaseID Returns the database ID of a device.

%Device.DisplayName Display Name (from Device Properties > General)

%Device.SNMPOid SNMP Object identifier. This is the word "unknown" if 
SNMP Object box is blank.

%Device.Status Down Monitors and a numerical value. Ex: 10|DNS

%Device.SNMPReadCommunity SNMP Community

%Device.State The state's description (such as "Down at least 2 min" or 
"Up at least 5 min")

%ActiveMonitor.State The Current status of the Monitor, such as "Down at least 5 
min." This variable only works on an Action or Action Policy 
that has been assigned directly to the Active Monitor (as 
opposed to the device in general.)

%Device.SNMPWriteCommunity SNMP Write Community (from SNMP section of Device 
Properties)

%Device.ActiveMonitorUpNames Full service names of all Up monitored services on a device

%Device.ActiveMonitorDownNames List of Down services using the abbreviated name if 
available

%System.NumberofDownDevices Number of Down devices

%System.DisplayNamesDownDevices Display names of devices with Down Monitors

%System.NumberofUpDevices Number of Up devices

%System.DisplayNamesUpDevices Display names of Up devices

 %System.Date The current system date. The format is mm/dd/yyyy

 %System.Time The current system  time. The format is hh:mm:ss

% Variable  Description
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Device Discovery

Using the Wizard

Through the Device Discovery wizard, you can scan your network 
for devices, using the protocol(s) and settings you choose. Once 
the devices are found, you select the ones you want to monitor, and 
WhatsUp Professional creates a device in the database for each 
item you choose. Device groups are created based on subnetworks 
that are found during the scan. 

The wizard begins by default after installation. After this initial 
Discovery, you can go back at any time for another Discovery by 
going to the menu bar and selecting File > Discover Devices.

Scan Types

There are four options for device discovery. They are:

• SNMP SmartScan: SmartScan discovers devices by reading 
SNMP information on your network. This scan type uses an 
SNMP enabled router to identify both network devices and 
subnetworks. We recommend using SmartScan as your pri-
mary Discovery method.

• IP Range Scan: WhatsUp Professional scans a range of IP 
addresses and finds the devices that respond to one or more of 
the chosen services. The Discover Devices wizard prompts 
you to enter a range of the IP addresses in your network. You 
should use IP Range Scan if SNMP is either unavailable or 
does not meet your needs. 

• Network Neighborhood: Scanning a Network Neighborhood 
creates a list of devices by scanning the Windows network to 
which your computer is connected, and finding the other sys-
tems on the network. Use this type of scan if you only want to 
discover Windows devices. 

Note: If some device group folders are empty, it is due to the 
fact that although a subnet was found, the devices in that 
subnet were either not scannable, or you chose not to 
monitor them.

Device Types

In this Chapter

Device Discovery - A 
Simulation

Adding a Single Device

Active Discovery
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• Hosts File Import: WhatsUp Professional imports devices from the system’s Hosts file, 
which is a text file that lists host names and their IP addresses on a network. For small 
networks, the Hosts file is an alternative to DNS. The Hosts file may also called a host 
table by some TCP/IP vendors.

For a step-by-step example of how to discover devices, see “Device Discovery - A 
Simulation” on page 100. 

Device Discovery - A Simulation
This section describes how to use the Device Discovery wizard using the SNMP SmartScan 
option to discover devices. In this example, you want to discover all of the SNMP-enabled 
devices attached to a specific router on your network. To accomplish this, you will have to:

• Know the IP address of the SNMP enabled router whose network you wish to discover.

• Know the Read Community name assigned these devices on the network.

Discover Devices

1 Select File > Discover Devices.

2 Select SNMP SmartScan as the method for scanning your network, and click Next. 
The SNMP SmartScan settings dialog appears.

3 In the SNMP Enabled Router box, enter the IP address of the SNMP enabled router 
you want to use for this scan.
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4 In the SNMP Read Communities box, enter the proper read community string for that 
router. If an incorrect string is entered, WhatsUp Professional will be unable to scan the 
network. Additional community strings may be entered, seperated by commas, if there 
are multiple SNMP enabled devices on your network which uses different strings.

5 Click the Advanced button if you wish to change the scan’s default timeouts in milli-
seconds, retry counts, and scan depth. Click the Limit scan to IP class of root device 
option if you want to limit the scan to the network class (A, B, or C) defined by the IP 
address of the root device. If the IP address is within the network class of the root 
device, the scan proceeds. Otherwise, the scan skips to the next IP address. Click the 
Resolve host names option if you wish to populate the list of discovered devices with 
host names in addition to IP addresses. Click OK. You are returned to the SNMP Smart-
Scan settings dialog. 

6 Click Next. The Active Monitors to Scan dialog appears. Select the type of Active 
Monitor you wish to use in this scan process. Let’s select Ping and Interface as our 
Active Monitors to be used in the scan process.
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7 Click Next.

8 The Device Discovery progress window displays the estimated remaining scan time and 
the scan’s progress. Click Stop if you wish to cancel this Device Discovery.

9 When the Discovery is over, the Devices to Monitor window appears, listing all of the 
devices just discovered. Note that if any of the devices have already been entered into 
the database, a shortcut to that device will be created in the device list. To add all of the 
devices to the database, click Next. To remove specific devices to be monitored from 
this list, clear the checkbox next to the device. Click Next. The Action Policy Selection 
dialog appears.

Note: Additional Active Monitors will not be added to devices that are already in the 
database.
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10 See Chapter 10 - “Actions,”  for an example of how to create Action Policies. If you 
choose not to apply an action policy you will see a Results summary, showing the num-
ber of selected new devices, number of active monitors, whether or not an Action Policy 
is applied, and the number of selected device shortcuts.

11 Click Finish to begin monitoring your devices. A progress bar appears while devices 
are added to the database; then the Device View appears.

Adding a Single Device
There are three ways to add devices to the monitoring database one at a time.:

• In the Map view, right-click and select  New > New Device , or  in the Device view, 
right-click and select New Device.

• You can display the Device Type list of device icons in the left hand pane, then click and 
drag one to the View pane.

• From the main menu, select File > New > New Device, or press <Ctrl+N>.
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Manual Addition - A Simulation

When you manually add a device by selecting New Device in a right-mouse menu, you are 
prompted to enter the IP address. Click Advanced to select Active Monitors to be used in 
the scan process. 

Once you click OK on the Add New Device dialog, WhatsUp Professional attempts to 
resolve the IP address or hostname, then scans that device for Active Monitors. When the 
scan is complete, Device Properties appears, allowing you to further configure the device as 
needed. To demonstrate, let’s add a printer to our device group.

1 Either click <CTRL+N> or right-click on the Map View and select New > New Device.

2 The Add New Device dialog appears. Type the IP address or host name for the device 
into the box.
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3 If you click the Advanced button, the Select Active Monitor Scan Properties dialog 
appears. If you wish, select one or more, click OK, and you return to the Add New 
Device dialog. Click OK. If the device already exists in another group, you will get a 
message to that effect. If you wish to add a short cut for the device in this new group, 
click Yes.

4 The Device Properties dialog appears. You can either accept the default Properties pop-
ulated when you added the device, or modify them using this dialog. If you accept them, 
click OK. For information on the Device Properties dialog, see “Device Properties” on 
page 48.

5 When you click OK, the new device icon appears in the Map View.

New Device Icon
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Click and Drag

Click and drag the device icon.

1 In the left viewing pane, select Device Types (Basic) or Device Types (Advanced), 
depending on which device type you desire. 

2 Drag the device icon to the map. When the icon is dragged into the Map View, the Add 
New Device dialog appears. The rest of the steps are identical to those in the “Manual 
Edition” section above.

Active Discovery
With Active Discovery, you can schedule WhatsUp Professional to scan your network for 
new Monitors and devices on a regular basis.  Newly discovered items are added to the 
Active Discovery Results report, and WhatsUp Professional notifies you that a new device 
was found, or a new Monitor was found on an existing device. You can then review the 
report and select the items you want to add to your device list.
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Active Discovery works with two types of Device Discovery:

• SNMP SmartScan - WhatsUp Professional discovers devices by reading SNMP infor-
mation on your network. This scan type uses an SNMP-enabled router to identify the 
devices in your network and also identifies subnetworks within your network. 

• IP Range Scan - WhatsUp Professional scans a range of IP addresses and finds the 
devices that respond to a message sent via the Internet Control Message Protocol 
(ICMP).

If the scan finds results, an e-mail is generated and sent to the address you provide during 
Active Discovery configuration. The e-mail contains links to the reports that are populated 
by the scan: the Active Discovery Log report and the Active Discovery Results report. The 
Log shows the success or failure of the Active Discovery task, and any devices and/or 
Monitors found during that scan. The Results report shows all new items found in the latest 
scan, or all unprocessed items from previous scans. Through this report, you can add devices 
to your device list.

Configuring Active Discovery

1 From the WhatsUp Professional main menu, select Configure > Active Discovery. The 
Active Discovery dialog appears.

2 Click New to add a new task, or select an existing task and click Edit. 
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3 If you are adding a new task, follow the wizard to create the task. Once the wizard is 
complete, the task will be processed according to the schedule you set, as in the screen 
above, for that task.

When the wizard is finished, Active Discovery appears. You can test your task by 
clicking Test. 

If your test is successful, the following message appears. 

4 Click OK to close the message.
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5 If you are editing a task, you must click the sections to which you wish to make 
changes. 

If you want to scan the devices currently in your databases for new services, make sure 
you select the Scan for new services on existing devices option. Clear the option to 
keep your existing devices from being scanned.

For further information on Active Discovery, please see the WhatsUp Professional online 
help.
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